[mythtv-users] wierd mpeg2video behavior

Michael T. Dean mtdean at thirdcontact.com
Sat Nov 19 20:04:17 EST 2005

chris at cpr.homelinux.net wrote:

>On Sat, Nov 19, 2005 at 12:58:30PM -0500, dave sailer wrote:
>>ha ha. right. I've played around and it seems certain recordings are 
>>giving these errors. I can quickly go thru using preview and figure out 
>>which ones but I'm not sure what steps to take next. Can I tell which of 
>>my two cards recorded a file? What other tools can I use to analyze the 
>I've seen these errors occasionally, and think it may be a case where 
>the machine was i/o bound and ivtv was generating data faster than Myth 
>could record it to disk.  Sometimes the video is still watchable, 
>although with lots of artifacts and occasional pauses.  The only real 
>solution I've found is to schedule it for re-recording.
>The first 4 characters of the filename are the channel ID.  You can look
>up that channel in the mythconverg database using:
>    select capturecard.cardid,videodevice,inputname from channel \
>    join cardinput on cardinput.sourceid=channel.sourceid \
>    join capturecard on capturecard.cardid=cardinput.cardid \
>    where chanid=9999;
>Substitute the channel ID from the filename in place of 9999, of course.
Of course, this won't help if you have the same source assigned to 
multiple capture cards.  The only sure-fire way (that I've ever heard) 
to know which card recorded a show is to look at the logs.


More information about the mythtv-users mailing list