[mythtv-users] and-hda-intel alsamixer has no 'Master' control

Kirby Bakken kirby at magnaspeed.net
Thu Nov 17 19:50:13 EST 2005

Deyan Bektchiev wrote:

> Steve Adeff wrote:
>> On Thursday 17 November 2005 18:09, Kirby Bakken wrote:
>>> Steve Adeff wrote:
>>>> On Wednesday 16 November 2005 20:31, Kirby Bakken wrote:
>>>>> I have a Gigabyte GA-K8N51GMF-9 motherboard; this board has a Realtek
>>>>> ALC880 chip.  I'm also running a gentoo 2.6.13-r3 kernel.  After I
>>>>> managed to find the ALSA device driver 'package' on the Realtek site,
>>>>> and got it working, I still couldn't get any sound out of 
>>>>> Mythtv...  I
>>>>> had the sound device set to 'ALSA:default', and the mixer to 
>>>>> 'default'.
>>>>> I finally decided to try changing the source code in 
>>>>> audiooutputalsa.cpp
>>>>> and change the code that was specifying 'Master' to instead specify
>>>>> 'Front'.  Lo and behold, sound now works in mythtv.
>>>>> I don't know how/why the alsamixer for the snd-hda-intel device I 
>>>>> has a
>>>>> 'Front' and no 'Master' control.....  all I know is that it 
>>>>> doesn't work
>>>>> the way it is, and my change made it work....
>>>>> How would I suggest to the mythtv 'development guy(s)' that this 
>>>>> might
>>>>> be a good addition?  Or was there an easier way to fix/change what 
>>>>> I had?
>>>> the ALC880 should work fine with the regular intel AC'97 ALSA 
>>>> driver. Did
>>>> you use the .asoundrc that floats around? audiooutputalsa.cpp is 
>>>> correct
>>>> in using Master, it is more compatible with how things are supposed to
>>>> work, you then use .asoundrc to "fix" for your issue.
>>>> Steve
>>> I understand that audiooutputalsa.cpp is correctly coded, but since I
>>> didn't (don't) know the ins/outs of alsa, and the asoundrc file, I
>>> 'patched' the code and was able to make progress...  But now that I've
>>> been shown the errors of my ways, I'd like to go 'back' to the right 
>>> way
>>> of doing things... Does anyone have a sample/example asoundrc file that
>>> I can use to 'change' the interface of my snd-hda-intel sound 'mixer'
>>> from 'Front' to 'Master', or even better, to ''add' a Master that would
>>> change the level of Front, Surround, Center, and LFE?
>> did you try the snd_intel8x0 driver(along with the snd_ac97 drivers)? 
>> I use it with my ALC650 and ALC850 mobo's.
>> as well, from what I understand, by default, the Master is the, well, 
>> master volume control, with front, surround, etc all being relational 
>> controls under the master control. Did you try raising the front 
>> volume all the way and using master after that?
>> Steve
> I have an ASUS mb with ALC680 and the only thing that worked for me 
> was alsa 1.0.10rc2 with the 1.0.10rc1 mixer (and I just saw that 
> 1.0.10 was just released yesterday...).
> Plus in the rc2 driver you actually have control over all channels and 
> the mode of the card 6 or 8 channel.
> Dejan
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> I've tried loading the snd_intel8x0 driver from a number of ALSA 
> versions, none work...  I downloaded also 1.0.10, and that one doesn't 
> work either.  The only set of drivers that I can get to work I got 
> from the Realtek website.  They're 'labeled'  
> realtek-linux-audiopack-3.5-1, and inside that (unpacked) dir is 
> alsa-driver-1.0.9b_21.tar.bz2, alsa-utils-1.0.9a.tar.bz2, and 
> alsa-lib-1.0.9.tar.bz2.  With the snd-hda-intel driver modprobed 'on', 
> I can bring up alsamixer, otherwise I get an error.....  Now at least 
> one 'odd' thing is that before I tried the upgrade to alsa 1.0.10, I 
> could see and set a 'PCM' slider in the alsamixer (or set it via 
> amixer), but now that doesn't show up anymore...  All I get are: 
> Headphone, Front, Front Microphone, Surround, Center, LFE, Side, Line, 
> CD, Mic,  Capture, Capture 1, Capture 2, Input Souce, Input Source 1 , 
> Input Source 2, and SPDIF.

More information about the mythtv-users mailing list