[mythtv-users] Nuvexport problems ffmpeg finishes immediately.

Jason McLeod anakin at sdf1.net
Tue Nov 15 19:57:27 EST 2005

Is there something special you need to compile into ffmpeg in order  
for it to read the fifos?

I've been having the same problem.  I'm trying to get a version off  
ffmpeg with aac compiled into it, to work with the mythtranscode fifos.

The ffmpeg version 0.4.9-pre1, build 4754 seems to work properly, but  
is missing aac.

When I download ffmpeg-0.4.9-pre1 source, and try and build adding  
aac, the build does not work at all with the fifos.

It exhibits the same behavior that you are experiencing.  I did have  
to downgrade my copy of nuvexport to the nuvexport-0.2-0.20050317.cvs  
package, as the newer 20051117 build was dying on yuvdenoise errors.

In case your wondering why so much work for aac, it's so I can encode  
for my iPod Video.


Blog: http://jayslife.com
GPG Fingerprint:
anakin at sdf1.net - A6CC 40B4 99A4 1C08 55A7  BCFC ECDF ED68

On 13-Nov-05, at 1:39 PM, Steven wrote:

> chris at cpr.homelinux.net schreef:
>> On Sat, Nov 12, 2005 at 11:21:18PM -0800, Chris Petersen wrote:
>>> Mythtranscode doesn't talk to ffmpeg -- nuvexport is what sets up  
>>> the two processes.  nuvexport *does* check for ffmpeg errors.  If  
>>> it's not trapping them, I need someone to email me the error so I  
>>> can add it in.
>> I solved half the problem.  I was running with a ffmpeg release from
>> September of this year.  When I rolled back to the March version the
>> "-hq" error went away.  The yuvdenoise problem is still there,  
>> though.
>> Can't you just check for the exit status and bail if it's non-zero?
>> With the later version, ffmpeg quits immediately but nuvexport  
>> just sits
>> there and waits and waits....
>> See my previous email for the exact output when I ran the command  
>> at the
>> CLI.
> I've been strugling to get nuvexport to create an xvid today and  
> ran into some of the same problems with the -hq option with ffmpeg  
> and also the -4mv option.
> Using transcode I got a "Audio format not supported by import module".
> Maybe it would be a good idea tho document the exact versions of  
> ffmpeg, transcode, yuvdenoise that were tested with nuvexport and  
> their configure build options.
> Steven
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list