[mythtv-users] Playing a DVD - no audio.

Nick knowledgejunkie at gmail.com
Mon Nov 14 17:54:08 EST 2005

On 14/11/05, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> Eric Ladner wrote:
> >I set up my Myth box (FC 4, myth rpm 0.18.1 build) using Jarod's
> >guide.  I have a Revolution 7.1 using the SP/DIF out with ALSA as the
> >main audio handler.
> >
> >The problem is even though taking the passthrough tip from Jarod
> >(specifically, the bit about "/usr/bin/mplayer -fs -zoom -quiet
> >-monitoraspect 16:9 -vo xv -ac hwac3, %s" in the tips and tricks), but
> >I still don't have any audio.
> >
> >I used the NForce guide to set up the asound(rc|.conf?) file and
> >things are working for normal audio.  How would I test the AC3 audio
> >with aplay to see if it's configured correctly?
> >
> >
> Set up your default audio device to "digital"  (not "mixed-digital") or
> specify the option "-ao alsa:device=digital".  The "mixed-digital"
> relies on a 2-channel-capable plugin for mixing that will corrupt
> AC-3/DTS streams.

*For the archive*

When setting up xine for AC3 pass through on a frontend, I just needed
to specify Pass Through as the speaker setup. The AC3 device default
is iec958, which worked perfectly on my system (my default ALSA setup
uses the mixed-digital device). Any non-AC3 material drops back to
PCM, which the AV receiver plays normally (I guess this is the
equivalent of the hwac3, used for mplayer on the command line)

I still get annoying skips when using MythMusic where tracks randomly
skip forward without any interaction, but I haven't gotten around to
seeing if this is S/PDIF related or MythMusic related.


More information about the mythtv-users mailing list