[mythtv-users] 18.1 frontend on OS X (localhost:6543 regardless of mysql.txt)

James Howison james at freelancepropaganda.com
Sun Nov 13 18:20:03 EST 2005

Hi all,

I can't get a frontend to work on Mac OS X.  Everything is working  
fine on linux and the little mediamvp (love that box :), so I know  
that Myth is setup and remotely accessible, but the OS X frontend  
seems to always want to contact localhost, regardless of the settings  
in the ~/.mythtv/mysql.txt file.

I'm currently using the build from http://anthonymittaz.com/ 
index.html and have tried both the CVS 0.18 and the 0.18.1 version.   
I've also tried a bunch of other OS X builds (eg, ) but none of them  
have worked for me.

Here's my config:

[james at MinistryOfInformation-2]$cat .mythtv/mysql.txt

MythFrontend.app starts but displays GANT instead of Blue theme and  
when I try to watch tv I get "Master Backend not found" and a message  
in the console about trying to speak to localhost ...

This is a cut from my console.log:

2005-11-13 17:44:12.921 Database not open while trying to save  
setting: Language
2005-11-13 17:44:12.943 Unable to connect to database!
2005-11-13 17:44:12.943 Driver error was [1/2002]:
QMYSQL3: Unable to connect
Database error was:
Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

2005-11-13 17:44:23.596 Writing settings file /Users/james/.mythtv/ 
Total desktop width=2304, height=960, numscreens=2
2005-11-13 17:44:24.013 Using screen 0, 1024x768 at 0,0
2005-11-13 17:44:24.099 Setting Lock for Database Schema upgrade. If  
you see a long pause here it means the Schema is already locked and  
is being upgraded by another Myth process.
2005-11-13 17:44:24.125 New DB connection, total: 2
2005-11-13 17:44:24.219 Database Schema upgrade complete, unlocking.
2005-11-13 17:44:24.224 mythfrontend version: 0.18.20050504-1  
2005-11-13 17:44:24.243 Enabled verbose msgs : important general
2005-11-13 17:44:26.123 Switching to square mode (G.A.N.T.)
2005-11-13 17:44:27.640 Registering Internal as a media playback plugin.
Identity added: /Users/james/.ssh/id_dsa (/Users/james/.ssh/id_dsa)
Identity added: /Users/james/.ssh/id_rsa (/Users/james/.ssh/id_rsa)
2005-11-13 17:46:01.099 Connecting to backend server: localhost:6543  
(try 1 of 5)
Connection timed out.
You probably should modify the Master Server settings
in the setup program and set the proper IP address.


It seems to me that it should be trying to connect to, not localhost:6543.  I tried tunneling that port  
and got a protocol mis-match (which is a step forward, I think, at  
least they spoke ;)

So does anyone know what the deal is here?  Why is the frontend not  
honoring the IP address of the server in ~/.mythtv/mysql.txt?  Is  
there a magic config setting that I'm meant to make, or is this a bug  
in the frontend on OS X?


More information about the mythtv-users mailing list