[mythtv-users] RE: Skip forward doesn't work correctly anymore

Steve Briggs zzybaloobah at yahoo.com
Sun Nov 6 01:36:51 EST 2005

Michael T. Dean wrote:
> Darren Hart wrote:
>> I am having a similar problem (maybe the same problem?).
>> I have run the above and came up with no errors.  I have run the 
>> repair on recordedmarkup.  I have checked the /etc/localtime symlink.  
>> I even went so far as to delete all the contents of the recordedmarkup 
>> table.
>And you rebuilt it again afterwards with mythcommflag?  Otherwise, it 
>will never work again on the recordings that existed at the time you 
>deleted the recordedmarkup "seektable" information...
>mythcommflag --rebuild --all
>And, if you also want commercials flagged
>mythcommflag --all

That doesn't agree with my experience.
After transcoding, the recordedmarkup table is empty -- but
THE ORIGINAL STILL SEEKS FINE -- it's only the transcoded
version that won't seek.
And, running mythcommflag --rebuild restores some of the recordedmarkup
table (didn't seem to restore all of it; it looked like there were big
gaps of "seekable" locations towards the end of the file), but seeking 
still doesn't work on the transcoded file.
What I don't remember (and can't check now; I'm out of town) is
whether seeking (on the transcoded file) is *any* different after
running mythcommflag --rebuild.  I know it still doesn't work, 
but it might not fail as bad.

Things I don't know:
1) What's the purpose of the recordedmarkup table if the original seeks
fine even with an empty table?
2) Is there some section of the .nuv file with seek info (positionMap?)?
3) If I need to run mythcommflag --rebuild after transcoding, why doesn't 
it just automatically do that? 


Yahoo! Mail - PC Magazine Editors' Choice 2005 

More information about the mythtv-users mailing list