[mythtv-users] KT400 playback of previously recorded video skips while recording a program simultaneously

Raphael Pooser rpooser at gmail.com
Fri Nov 4 18:58:59 EST 2005

This is my first post to mythtv-users.  I built my mythtv box somtime 
back in August.  It took me about 2.5 weeks to set it up (grueling) 
trying this or that distribution and many different driver 
combinations.  Now that mythtv is working 99% properly it is a pretty 
amazing program.  It's kind of shocking but this not only works better 
than the equivalent windows solution (MCE2005), it works better with 
less horsepower under the hood, and driver support for some of my 
components is actually less buggy than under windows.  Well that's 
another post; the subject of my current discussion are just a couple of 
minor problems here or there that I can't seem to solve by myself just 
yet.  In order to detail the problem, I'll provide a short history of 
the evolution of the mythtv machine so that if anyone sees something 
that might have been done to actually cause the problem, they might be 
able to point it out.  If you don't want to go through such boredom you 
can skip to the last paragraph which describes the problem in detail.   
Here's a little background info on my problem starting with my current 

Motherboard: Gigabyte GA7VAX; chipset: VIA KT400; BIOS: F4
Graphics card: ATI 9600pro (sapphire brand)
Sound: onboard, realtek something or other, one of those onboard 6.1 
channel numbers.
TV tuner: ATI TV wonder pro (uses connexant)
Remote: ATI remote Wonder
Processor: Athlon XP 1700+ Palomino core
Ethernet adaptor: Zonet 802.11g card (ralink 2500 chipset)
HD1: Maxtor 80GB 7200RPM ATA133, 2MB buffer (Diamond Max Plus 9) - 
stores root filesystem and mythtv recordings.
HD2: Maxtor 80GB 5400RPM ATA133, 2MB buffer (Diamond Max Plus 9 or some 
such) - stores mp3s and mame roms.
NEC 24xCDROM drive - used for nothing once OS has been installed.

Software configuration:
Distro: Ubuntu Hoary
Desktop: gnome 2.x - ubuntu hoary default
Display driver: ATI proprietary fglrx module, latest version, but only 
software OpenGL using Mesa
Ethernet driver: ra2500 compiled as a module from latest release
Sound system driver: via82xx - ALSA, hoary default version
TV tuner driver: cx88xx module (connexant), hoary default version
Remote control: ati_remote module - hoary default version
Remote implementation: X input device with xmodmap to assign key controls
Mythtv version: 0.17 - the latest version in ubuntu universe repositories
Mythtv plugins version: see line above
Working mythtv plugins: Mythmusic, mythgame
Partially working mythtv plugins: Mythweather (never can download 
satelite image), mythweb (can view and make bookmarks but cannot browse 
any pages due to error "kdelib not meant to run with root priveledges" 
forgot exact offending library but some such, unable to view mythweb 
html pages due to php syntax errors).  mythtnews (can view rss headers 
but no browsing).
mysql: latest hoary repository version
apache: see line above
php4: see line above
Basically all supporting myth software is at ubuntu hoary latest 
repository level
Special hdparm commands: hdparm -M128 /dev/hda; hdparm -M128 /dev/hdb; 
hdparm -B120 /dev/hdb (puts second HD to standby after 5 minutes)
hdparm shows DMA on
Athcool version: latest ubuntu repository version.  "sudo athcool on" 
command issued upon startup
Recording quality: 480x480 RTJPEG quality170 MP3 48kHz quality3- 40% 
processor utilization
LiveTV quality: 384x480 RTJPEG quality170 MP3 48kHz quality4- 40% 
processor utilization
watching recording: 10-20% utilization
Recording+watching recording - 60-80% utilization
This machine is set to run as the backend and I use it for my frontend 
as well

Brief history of the setup arriving at current above config:
Original configuration: Same as above except motherboard is replaced 
with an EPoX mobo with viaKT266A chipset, sound is replaced with a Sound 
Blaster Live Value
Distros tested: Mepis -compiled mythtv 0.18 from source along with all 
dependancies.  This was the most trouble in terms of getting it working, 
but I did have a working mythtv box there.  No mythplugins would compile 
or install no matter what I tried., so I moved on to Mandrake 10.1.  
This was the slowest of all the distros I tried, also could not get 
sound working without unwatchably bad quality of no end to hissing and 
popping, so moved on to Knoppmyth.  Knoppmyth installed a working mythtv 
distro, but with extremely low video quality (355x240) I still had 95% 
processor utilization.  Anything higher and I got prebuffering pauses or 
whatever they are called.  On to Ubuntu (easiest distro I have ever 
installed).  Mythtv worked using 0.17 which is in the ubuntu 
repositories.  Followed an online guide for mythtv under ubuntu 
specifically and was up and running.  Bad video tearing and intermittent 
beeping noises during recording or playback.  Moved TV tuner card from 
last PCI slot to third; perfect video capture now and no beepng noises.  
Installed mythplugins, able to access mythweb server from other machines 
at first, then inexplicably have lost this functionality.  Last 
remaining problem with recording involves occasional popping noise with 
sound, nothing I couldn't live with and I started regularly watching 
recordings.  Watching a recording while simultaneously recording a show 
works perfectly.  Perfectionism leads me to search for source of 
intermittant popping.  Replace old KT266A mobo with less old KT400 one, 
long believed dead, once supported a windows machine, now resurrected by 
linux somehow (I cannot explain it, it stopped booting about 1.5 years 
ago and I even got a warranty repair which didn't help, it stayed in a 
closet for 1.5 years and now not only boots reliably every time, but 
runs linux, not M$).  At this time install athcool and issue hdparm 
command to quiet down main HD.  Install new HD with music and games on 
it.  hdparm it to quiet it down too.  The mobo switch was made due to 
belief that older via mobo had problems giving soundcard adequate power 
with agp slot in use.  Popping noise is reduced even more and almost 
nonexistant.... BUT still there from time to time!  Next theory, ALSA 
drivers for SBLive are bad.  Remove SBLive and use onboard sound.  
Bingo.  Sound is absolutely perfect.  This step could not have been 
taken with previous kt266 mobo because the onboard sound was unusable on 
it: insane clicking and popping with any sound that would emanate from 
the line out.  Mythtv box is now 100% usable with good remote support 
and good sound with good video quality, and quiet hardware, running cool 
due to athcool.  Last nitpicks include the mythweb server not working, 
mythweather not downloading radar map.  Those are pretty minor admittedly.

Now, the last problem I have to solve before my mythtv machine is 100% 
operational and better than a TiVo could be, with no problems whatsoever 
after this:
If the the machine is recording a TV program and I want to watch a 
recording simultaneously, the playback skips whenever I try to seek by 
jumping _ahead_, fast forwarding, or by skipping commercials.  Jumping 
back does not cause this problem.  Also, if the skipping occurs, and I 
pause it for a few seconds, and then resume playback, the skipping will 
stop until after my next forward seek.  The skipping also ocurs if I am 
already recording and select to watch a recording; the skipping starts 
as soon as the playback starts, and the pause tricl works.  Without 
recording at the same time, seeking is flawless.  Setting hdparm -M254 
or -M0 does not help, nor does setting athcool off.  So this must be 
related to the HD directly or the mobo-HD insteraction.  Tried an 
experiment: go to program guide and select a show to record.  Now go to 
"watch recordings" and watch this recording while it is being recorded.  
Skipping problems ocur, ok expected.  Now, go to watch live TV, I should 
see skipping, because it is doing the same as playing back a recording 
while it is being recorded.  *NO* skipping watching live TV!  Why?  Live 
TV plays back perfectly.  Does anyone know anything about this?  Anyone 
else using a KT400 and encounter this problem?  Can I fix this problem 
by increasing the read ahead using hdparm.  Defualt for most drives 
seems to be 4KB, maybe if I set it to like 64KB or even higher, the 
playback will not skip because it is able to keep the data stream 
unbroken due to increased read-ahead.  Anyone got any suggestions about 
what read-ahead to use or iedas about why it would or wouldn't work.  
Thanks everyone who can help and thanks for holding out on this long 
post.  Mythtv is great and it can only get better at this point.  A real 
triumph for linux.  Let's hear it for the analog hole.

More information about the mythtv-users mailing list