[mythtv-users] RE: nForce4 Audio on FC4, it plays some of the time....

Mark Knecht markknecht at gmail.com
Thu Nov 3 07:27:34 EST 2005

On 11/2/05, Jason Sharpe <mythtv.list at gmail.com> wrote:
> > ------------------------------
> >
> > Message: 15
> > Date: Wed, 2 Nov 2005 14:12:43 -0700
> > From: "James C. Dastrup" < jc at dastrup.com>
> > Subject: RE: [mythtv-users] nForce4 Audio on FC4, it plays some of the
> >        time....
> > To: "Discussion about mythtv" < mythtv-users at mythtv.org>
> > Message-ID:
> <3B588E7A10420448AE571D9E921247867346 at foo.dastrup.com>
> > Content-Type: text/plain; charset="iso-8859-1"
> >
> > I had a very similar problem. I was finally able to figure out that KDE
> was messing with my alsa settings everytime it started, even when I told it
> not to. You can test this by opening up alsamixer and while your audio is
> playing, mess with the settings until you hear something.  I solved this
> problem by simply putting a script in KDE's /.Autostart folder, so after KDE
> starts, my mixer settings go back to the way I want them.  You can find more
> detail at http://www.dastrup.com/template_mythtv.asp and
> look in the Audio section.
> Thanks James for replying,
> I took your suggestions and tried messing with alsamixer while playing
> something, I never heard audio no matter what I tweaked.
> I looked at your site and was going to look at your script and your
> .asoundrc, however I can't get to your FTP site. It just times out when I
> try to visit the FTP links. I tried from both work and home and I can't get
> to them.
> The program that opens by default when I double click the .au file is
> "Noatun". I can play the file all day long and it will sound just fine,
> however aplay still won't create audio.
> Just for kicks I disabled the sound system in the KDE Control Center and
> rebooted, I was still able to play the sound from Noatun, but not with
> aplay.
> Can you email me the scripts that you link to in the audio section of your
> website?
> Thanks
> Jason

I have an NForce4 MB running Gentoo. I use pretty much prerelase Alsa
stuff. CVS, etc., depending on my needs. I also am running 2.6.14-rt4,
but audio worked with earlier kernels also. I run MythTV's frontend on
this machine and have no audio problems at all with the on-board sound
hardware. Works perfectly for my needs.

This is most likely a Fedora release issue. Consider updating Alsa and
possibly your kernel.


More information about the mythtv-users mailing list