[mythtv-users] Watch TV sends audio to PVR-350 audio-out, but recordings don't---any clues?

f-myth-users at media.mit.edu f-myth-users at media.mit.edu
Tue Nov 1 13:51:28 EST 2005

I have one more data point:  I took one of the recordings I made and
copied it to another machine.  (E.g., I just scp'ed one of the .nuv
files from /myth/tv elsewhere.)  mplayer plays the video just fine, and
-claims- that there's audio there (filter chain 48000Hz/2ch/16bit),
but I hear nothing.  Playing some other random .mov on the same
machine does give me sound.  So I'm beginning to think that there is
no sound actually laid down in the audio in the recording.

The question is, why?  I would naively assume that using the same
tuner for both live TV and recordings should initialize it exactly the
same and lead to the same results, but this is clearly not happening
here.  So how do I even begin to debug this?  I see other people
who've complained about audio in recordings but not live, but my
situation is exactly reversed, and I don't have any good idea about
where to really begin as far as uncovering the cause.

[One of the common failure modes I see from the archives is a muted
tuner; mine doesn't -appear- to be muted, since "ivtvctl -a" reports
"Mute = 0" at the very end of its run.]

[I tried copying a random .mov back into /myth/tv and renaming it in
place of one of the .nuv's and playing the replacement; I got very
slow video & no audio, probably because it was a random framerate and
certainly a different audio rate (44.1KHz).  I could poke around
for something that more closely approximates one of the .nuv files, or
transcode something, just to see if I get audio -out- of presented
correctly, but since live TV gives correct video & audio, I'm guessing
that I have really only one bug---no audio on the recordings.]


    Date: Mon, 31 Oct 2005 16:04:07 -0500 (EST)
    From: f-myth-users at media.mit.edu

    [Please keep me CC'ed or I probably won't see replies in a timely
    fashion!  And if this is more appropriate for the -dev list, please
    either forward or tell me and I'll forward.  Tnx.]

    I've been installing a two-machine MythTV setup based on KnoppMyth
    R5A22, and I've been running into problems that the people on the
    forums there don't seem to have heard of; I'm hoping that people here
    have, and can help.

    The setup:

    My current setup has a master backend machine with several Hauppage
    PVR-250's in it, and secondary backend that I'm also using as a
    frontend, because it has a single PVR-350 in it; that's the machine
    that I'd like to use to watch video from.  (I haven't yet configured
    the 350 as a capture card, so I'm only using it as an output channel
    right now.  See the PS.)  Both machines are identical Athlons running
    whatever comes by default on the KnoppMyth R5A22 ISO, and started from
    blank disks.

    The machines were set up as MBE/FBE using the instructions at [1], and
    the 350 was configured using the script at [2].  (Note also that [2]
    installs a new version of ivtv, in case that matters; I -suspect that
    it installed something from 0.4.0 but I'm not sure and am not sure how
    to positively identify the version number I'm using; if anyone thinks
    this is an ivtv problem and that this matters, can you advise on how
    to check?  Tnx.  [And if it did install a new ivtv, it did so only
    on the SBE/FE (1x350) machine, not on the MBE (Nx250) machine, because
    I ran the script on the SBE only.])

    Both [1] and [2] ran into snags having to do with the database.  For
    the MBE/FBE setup in general, it's theorized that recent mythfrontend
    builds have a bug in how they initialize the database such that the UI
    works but Watch TV breaks; see the last page of the long thread at [3]
    detailing how I got screwed by this and was eventually able to fix it
    (with a workaround which is not clear to me is correct, but seems to
    work---expert opinions appreciated).  For the 350 setup, the script
    was never tested in a two-machine setup (its author has only a
    single-machine configuration), and I had to go in and actually make
    the database edit manually that it was trying to do; see [4] for that.

    The problem:

    I'm currently in the situation where, if I select Watch TV, I get
    audio and video from the 350's outputs just fine.  These are coming
    from one of the 250's on the backend machine, which is trivially
    provable by (a) the fact that the 350 isn't configured yet as a
    capture card, and (b) the fact that the 350's RF-in isn't even
    connected.  So clearly frontend/backend communication is working..
    (Not to mention that I'm using an IR receiver plugged into the 350's

    But if I record a show and then try to play it back, I get video just
    fine from the 350, but no audio anywhere (not on the card, and not
    from either motherboard soundcard output).  This smells to me like
    some sort of database misconfiguration somewhere (perhaps only
    because I got screwed twice by such things), but for all I know is
    something completely different.  I just don't have a clue where to
    look or how to even debug the situation; I'm finding detailed
    documentation about the innards rather scarce on the ground and would
    appreciate ideas about where to even look (short of "pull all the
    source and read it").

    The only other thing I can think of to try would be to put a spare
    disk in the SBE (the one with the 350) and do a single-machine install
    onto it, then run the 350 TVout script, and see if recorded audio
    works -at all- to a 350 in the R5A22 KnoppMyth distribution even in a
    single-machine configuration; if it does, I could at least dump the
    database and compare every setting in it to the database I've
    currently got.  That's a few hours of work, and I'm not even sure this
    is a database problem in the first place, so I'm reluctant to do this
    unless no one else has ever seen this problem before (which seems

    I'm not even sure how to figure out if audio was even -recorded- in
    the recorded video, although I'd be a bit surprised if it wasn't,
    since it seems that playing live TV using (presumably) the same card's
    tuner works just fine.

    Can anyone help or lend some suggestions?  Has anyone seen this
    behavior before?


    [1] http://mysettopbox.tv/linhes.html
    [2] http://mysettopbox.tv/phpBB2/viewtopic.php?t=3886
    [3] http://mysettopbox.tv/phpBB2/viewtopic.php?t=6618
    [4] http://mysettopbox.tv/phpBB2/viewtopic.php?t=6683

    P.S.  I have yet to find a clear explanation of one configuration
    detail:  In a two-machine setup of the type I have, which machine
    should I configure the 350 on if I'd like to make it a capture card?
    Should I run mythtv-setup on the SBE (aka the FE, aka the machine that
    has the 350 physically installed in it)?  That's my guess, since
    otherwise it's completely unclear to me how mythtv-setup knows which
    card is installed in which machine (especially if there are, say, -3-
    machines...), but on the other hand, both the machines are talking to
    a single master backend that's on one of them (currently the one with
    the 250's in it), so perhaps it's the backend where this needs to be
    run.  The actual architecture of which machine stores what is fairly
    unclear to me, since I'm not sure where other bits of state are being
    held that might not be in the SQL database on the backend---or what
    almost all of the various entries in that database are supposed to
    mean, for that matter.

More information about the mythtv-users mailing list