[mythtv-users] lirc_atiusb freezes

Niklas Brunlid nbr at ticalc.org
Sun May 22 12:55:52 UTC 2005

On Sun, 22 May 2005 14:28:35 +0200, Niklas Brunlid <nbr at ticalc.org> wrote:

> I just got the ATI remote wonder so that I could move my frontend away
>  from the TV sith long SVideo cabled ans stuff.
> When I try to load LIRC with /sbin/modprobe lirc_atiusb, the console just
> hangs. The rest of the system keeps on running just fine, and the LIRC
> atiusb stuff appears in the system log (dmesg), but if I start lircd and
> try to use irw lircd just exits.
> I am not loading the ati_remote module simultaneously. When i try to use
> it, it loads fine with modprobe and shows upo in the system log, but then
> it does nothing.
> When I plug in the receiver after a fresh restart (no ati modules loaded
> at all) the system log says nothing.
> I run on FC3 installed with Jarod's guide.

Got one step further by removing all references to lirc_atiusb in  
/etc/modprobe.conf, so now the lirc_atiusb module loads fine. Still not  
automatically, but it doesn't hang the console.

Lirc still doesn't work though:

(console 1): /usr/bin/lircd -n
(console 2): irw
(console 1): lircd-0.7.1[4429]: lircd(any) ready
              lircd-0.7.1[4429]: accepted new client on /dev/lircd
              lircd-0.7.1[4429]: could not get file information for  
              lircd-0.7.1[4429]: default_init(): No such file or directory
              lircd-0.7.1[4429]: caught signal

In /dev/ I have:
[root]# ls -al /dev/lirc*
srw-rw-rw-  1 root root 0 May 22 14:54 /dev/lircd

Shouldn't this be a (c)haracter device?

/ Niklas

More information about the mythtv-users mailing list