[mythtv-users] Re: Dying Backend

Gavin Haslett gavin at nodecaf.net
Tue May 17 19:09:36 UTC 2005

I say that it's during database writing because if I'm just READING the database it almost never seems to die. Basically I see it when scheduling recordings (mythweb most common, but on occasion through Mythfrontend), deleting recordings (removed record from the database, again most often in Mythweb but still happens in MFD), after running mythfilldatabase (often dies a minute or so after MFD runs), and when recording finishes and commflag is about to start. I should clarify that last one; I run that AFTER recording, not during recording as I'm unsure how happy my AMD 800 would be with that.

I have noticed that if I just WATCH recordings (a task that doesn't write to the database at all) then it doesn't crash... but what would be the point of that?

I think part of the backend problems might be database-related. I've had occasional problems with MySQL with my own developed applications where it doesn't seem to commit the writes back to the database files correctly, or takes a lot longer than I expect for it to write. It doesn't seem consistent... I just trap for the error and verify writes now. Sure it slows my code, but it prevents my code from segfaulting after a failed write.

-----Original Message-----
From:	mythtv-users-bounces at mythtv.org on behalf of Larry Taub
Sent:	Tue 5/17/2005 11:24 AM
To:	mythtv-users at mythtv.org
Subject:	[mythtv-users] Re: Dying Backend
I am right there with you Gavin. I have been experiencing the same problems 
as you report. I had not noticed the correlation with the database writing 
but I hadn't looked for it either. I have noticed many crashes directly 
relating to scheduling recordings in Mythweb. Also, I recorded about 10 
hours worth of tv yesterday and it worked fine then all of a sudden, it 
crashed on an evening recording. When I woke up this morning, I saw that it 
recorded two late night shows fine and was still running but then it crashed 
on a morning show today. I took the opportunity to upgrade to .18.1 and have 
restarted it. When looking at the logs, nothing seems amiss even when I 
turned up the logging verbosity to all. It just shows that recording is 
starting and then the log ends. I tried turning off the commercial flagging 
while it records and it still crashed. To give another data point, I am 
running off the atrpms install of mythtv. 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 3697 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20050517/7d7c2847/attachment.bin

More information about the mythtv-users mailing list