[mythtv-users] Occasional problem starting mplayer from MythVideo

Michael Carland mcarland at bitsgonewild.net
Mon May 16 20:57:13 UTC 2005

I should probably post this over on an mplayer list, but since it is 
happening under Myth, I thought maybe someone here has seen this.

mplayer (1.0pre6-3.3.5) usually works when MythVideo starts an mpeg2, 
but when it doesn't, it tries to display an untitled window. Once the 
window is placed it immediately dissapears, so I do not know what it 
says. If I place it with clicking the mouse, the window dissapears, and 
I can try and select the video again. If I add "RandomPlacement" to my 
.twmrc so I don't have to get up and hit the mouse, I am not asked to 
place the untitled window, but Myth appears to be hung without some of 
the video selection screen redrawn.

When it is working, the "Trying to re-lock decoder" message is printed 
thousands of times, so when mplayer does not work the error would seem 
to be "X11 error: BadDrawable (invalid Pixmap or Window parameter)". 
Nothing odd appears in my Xorg.0.log.

I would say calling mplayer works about 9 times out of 10. My player 
settings for mplayer are "mplayer -fs -zoom -quiet -vo xvmc:deint-bob 
-vc ffmpeg212mc %s"

If someone knows how to get mplayer to fail without either requiring 
the untitled window be places, or locking up Myth, I'd be happy with 
that. If there is a way to get mplayer to not fail, that would be 
ideal. Any tips on getting the thousands of "re-lock decoder" errors 
from appearing in the logs would be appreciated as well. XvMC is 
otherwise working.

If this doesn't look familiar to anyone, I'll try the Unichrome or 
mplayer lists.



VDec: vo config request - 480 x 480 (preferred csp: MPEG1/2 Motion 
Compensation and VLD)
VDec: using MPEG1/2 Motion Compensation and VLD as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xvmc] 480x480 => 640x480 MPEG1/2 Motion Compensation and VLD  [fs] 
ViaXvMC: ERROR: Trying to re-lock decoder.
X11 error: BadDrawable (invalid Pixmap or Window parameter)
vo_xvmc: Port 64 grabed
vo_xvmc: Found matching surface with id=32315659 on 64 port at 0 adapter
vo_xvmc: Allocated Direct Context
vo_xvmc: Motion Compensation context allocated - 8 surfaces
vo_xvmc: idct=0 unsigned_intra=0
vo_xvmc: looking for OSD support
     Subpicture id 0x34344149
vo_xvmc: OSD support by beckend rendering (fast)
vo_xvmc: Pleace send feedback to configrm that it work,otherwise send 

MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
   It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
   gcc version. If you think it's MPlayer's fault, please read
   DOCS/HTML/en/bugreports.html and follow the instructions there. We 
can't and
   won't help unless you provide this information when reporting a 
possible bug.
alsa-uninit: pcm closed
X Error of failed request:  BadWindow (invalid Window parameter)
   Major opcode of failed request:  2 (X_ChangeWindowAttributes)
   Resource id in failed request:  0x80000b
   Serial number of failed request:  120
   Current serial number in output stream:  126

More information about the mythtv-users mailing list