[mythtv-users] Fedora 3 and SUID

Xiaotian Sun sun.xiaotian at gmail.com
Tue May 10 20:28:58 UTC 2005

On 5/10/05, Rich Goodin <rich at goodin.com> wrote:
> Is anyone using Fedora Core 3 and SUID successfully?
> When I run mythfrontend as root I get the confirmation that it is
> able to up the priority of the thread as expected. Then I make
> mythfrontend SUID root by:
> chmod root.root mythfrontend
> chmod a+s mythfrontend
> I made sure that selinux is not enabled by:
> - passing selinux=0 at boot
> - removing it from the kernel compile
> - set SELINUX=disabled in /etc/sysconfig/selinux
> When I run as a normal user, I still get the warning message from
> mythfrontend:
> "Realtime priority would require SUID as root"
> I've searched the archives with no luck. All the hits just mention
> the "chmod +s" and the possibility that selinux disables SUID. Any
> idea what I'm missing?

Seems I'm having the same problem.  Never enabled selinux on my machine.  

> Rich Goodin


More information about the mythtv-users mailing list