[mythtv-users] MythDVD Not Playing DVDs

Derek Battams derek at battams.ca
Sat May 7 23:00:24 UTC 2005

Got my myth box moved to the tv... watching live tv/recordings displays fine.
But I can't play a DVD.  When I try to start it in MythTV I can see it reads
the disc, the screen goes black then it returns to the MythDVD menu.  So I then
copied the mplayer command from the Myth setup and tried to run it from the
command line.  Same thing happens.  The mplayer output is below.  I'm using a
GeForce FX 5200 directly connected to my TV via S-video.

Help appreciated,


[mythtv at mythtv-server ~]$ mplayer dvd:// -dvd-device /dev/dvd -fs -zoom -vo xv
MPlayer 1.0pre7-3.4.3 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing dvd://.
libdvdread: Using libdvdcss version 1.2.8 for DVD access
Reading disc structure, please wait...
There are 24 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient
DVD successfully opened.
Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll,
MPEG-PS file format detected.
MPEG: No audio stream found -> no sound.
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  7000.0 kbps (875.0 kbyte/s)
vo: X11 running at 800x600 with depth 24 and 32 bpp (":0.0" => local display)
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 720x540 Planar YV12  [fs] [zoom]
V:   0.7  15/ 15 ??% ??% ??,?% 0 0

Exiting... (End of file)

More information about the mythtv-users mailing list