[mythtv-users] Mythtv playback problem with NVIDIA videoa cceleration - HELP! (still unsolved)

Howard Cokl hojoloco at yahoo.com
Tue Mar 29 12:51:48 UTC 2005

On Monday 28 March 2005 22:42, intent wrote:
> On Mon, 28 Mar 2005, Scott Matheson wrote:
> > I'm having the same problem. I went backward from 7167 to 6629 but the
> > DVI interlace bug came back (I am audio authority-less, so it's DVI or
> > nothing)... not good. Would compiling from CVS fix the problem? How do
> > I make sure it's building against the 7167 library? Or is it really a
> > runtime issue? (I tried relinking everything by hand, but no dice under
> > 7167.)
> I've updated to 7167 using Nvidia's installer. I've found that MythTV's
> performance display SD and HD content has improved somewhat with the new
> drivers. XvMC is still unstable however.
> The performance problems I'm seeing with mythtv are strange. For example,
> I have two recorded shows, one plays back perfectly, the other looks like
> only every second frame is being displayed. With XvMC everything plays
> back perfectly, however the frontend is pretty much guaranteed to crash
> eventually (sometimes you get hours, sometimes minutes). I have to
> investigate the differences between the two recordings further.
> Another thing I tried was, while recording a show in mythtv, playing back
> other previously recorded nuv files in mplayer. They all played well at
> the full framerate. Something in mythtv's mpeg2 playback is odd (using the
> libmpeg option or not) or I've configured something incorrectly.

I've been fighting with this for a couple of weeks now, ever since I got my 
pcHDTV3K.  I have recompiled myth with debugging and ran mythfrontend with 
gdb, nothing.  If I disable agp completely I can get it to work, so figured 
it may be the via chipset on my Abit VA-10.  Went out and bought a new mobo 
with an nforce chipset, did a complete reinstall, built myth from source .17 
and the same problem.  Some hard lockups requiring a reset, box is pingable 
but otherwise dead, some softlockups where X is taking all the CPU cycles to 
say "SIGALRM (Alarm clock) @ 0 (0)" repeatedly.  Looked on nvidia forums, and 
saw similar problems but no solution.  At this point I've mucked around so 
much I probably should do a fresh install of everything.  

Slackware 10.1
MSI K7N2GM-L onboard video w/TV out
Athlon 2700+

Howard Cokl
"in a world without walls and fences, 
who needs windows and gates?"

More information about the mythtv-users mailing list