[mythtv-users] ff/rew problems with Internal player on Videos

jondz jondz at dca.net
Wed Mar 23 16:57:44 UTC 2005

On Wed, 2005-03-23 at 09:16, Joseph A. Caputo wrote:
> On Tuesday 22 March 2005 10:32, Donavan Stanley wrote:
> > On 21 Mar 2005 23:04:50 -0500, jondz <jondz at dca.net> wrote:
> > > (Internal player).  I put "internal" on the video
> > > player (instead of mplayer).
> > > 
> > > FF/REW/Page up/down wont work with playing videos,
> > > the ff/rew are mostly too slow.   Page up/down
> > > will delay for too long (10,30 seconds) then
> > > mostly wont work anyway (might move forward only
> > > a few frames or just jump backward).
> > 
> > You need to build a seek table for them using mythcommflag.
> I was actually going to post about this... I've tried everything I can 
> to get seeking to work in my movie rips, to no avail.  I saw a post 
> recently that mentioned it's necessary to run 'mythcommflag --video' 
> with the *full* path of the video file (rather than the path relative 
> to the video dir).  I've tried both ways, and while the results were 
> different, neither was a success.  I've verified that the movies have 
> seektables in the 'filemarkup' table.  At best, what seems to be 
> happening is that the video seeks properly, but the audio doesn't, so 
> the video freezes until the audio catches up.  I'm not sure if that's 
> actually what's happening, but that's the appearance it gives.  I 
> should mention that most of my movies are XviD AVIs (most produced by 
> MythDVD, some by DVD::Rip), as I seem to recall that AVI seeking was 
> less mature than some other kinds.
> I'd be happy to do anything necessary to help debug this.
> -JAC

I have exactly the same problem!

Last nite I did a few tests with mythcommflag --rebuild ---video
/path/to/movie and the Page up/down worked---but the audio were
thrown out of sync.

In my case the video didnt freeze but the audio was just way
out of sync (about 2 seconds late or early i'm not sure).


More information about the mythtv-users mailing list