[mythtv-users] MythVideo database resetting itself afteraddingsecond frontend

Darren Richards darren.richards at gmail.com
Tue Mar 15 05:53:37 UTC 2005

On Mon, 14 Mar 2005 21:10:20 -0800, Ian Forde <ian at duckland.org> wrote:
> On Mon, 2005-03-14 at 21:49 -0700, Darren Richards wrote:
> > Thanks for the suggestions.  This will work in about 95% of the cases,
> > but there are certain dvd's which require special options (like -aid
> > 128).  But specifying -aid 128 for all dvd's cause most of them to not
> > play in dolby digital, even though I also specify ac=hwac3.  So I need
> > to specify separate options on a per-movie basis.
> >
> > I suppose I could make the script smart enough to supply different
> > arguments based upon the filename.  Perhaps I'll try that.
> No problem - what you could do is have a .desc file with the same
> basename as the movie.  Within that, you could specify the options that
> you want to call mplayer with.  From your script, you check for .desc
> file for options.  You would also need to configure mythvideo to
> ignore .desc files the same way that .log files are ignored by default.
> Another (and probably smarter) way would be to give them a different
> extension, so you could invoke mplayer on those particular files with
> the -aid 128 option...  The idea (for me, at least) is to avoid file-
> specific options as much as possible and group movies into classes.
> That's why I use .vob for avi files with AC3, and .avi/.mpg for the
> others (with the exception of .dvdrip which is a straight iso that I use
> xine for.)
>         -I

Thanks, Ian.  Great suggestions.  I'll have to whip up a script to do
something along those lines.


More information about the mythtv-users mailing list