[mythtv-users] Everything working except one thing

Ron_Pepper at Dell.com Ron_Pepper at Dell.com
Tue Mar 8 17:33:38 UTC 2005

Hi all,


            Just wanted to say that I have been a lurker for a long time
and have been playing with mythtv for a long time as well.


            I have everything working right now except for one thing,
that is a Xbox frontend.


            Here is what I have:


            Backend server:

            2.8 P4

            512M RAM

            2 PVR-250 cards

            1 HD3000 card (not configured currently)


            Running Gentoo with mythtv 0.17




            Xbox (software mod only (mech assault installer), no
hardware changes)

            Xebian (latest release, 1.0.3?)

            Mythtv-xbox from http://bit.blkbk.com
<http://bit.blkbk.com/>  0.4.4


            The install of the frontend went well enough, although
trying to do the full xebian install from the install script at
mythtv-xbox didn't do anything, so I did a normal install from a DVD-R
(my xbox doesn't like CDRs-phillips drive I think).  After installing
xebian I ran the mythtv-xbox install script which installed everything
from the looks of it.


            Everything works except the audio (via the optical digital
out).  I looked at several posts regarding this, and saw some references
to modifying the modules.conf entries (via /etc/modutils/alsa).  I
wasn't able to get xbox=1 to stick in alsa, so I unloaded the
snd-intel8x0 driver and loaded again via "modprobe snd-intel8x0 xbox=1".
This loaded, but reported xbox=1 is not a valid option.  Checking the
logs via dmesg, when the driver is loaded automatically or via modprobe
it reports that AC'97 isn't responding and is reset.  I assume this is
my core problem, but I can't seem to find a way to make it work.


            I also tried getting the kernel source and building alsa
from scratch, but configure -with-cards=intel8x0 reports that intel8x0
isn't a valid card (despite being listed as an option in configure.


            So, any ideas on what I can do to get my audio working?






-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050308/c4ee1732/attachment.htm

More information about the mythtv-users mailing list