[mythtv-users] TV won't play unless you run mythbackend manually from a console (Success)

Nick knowledgejunkie at gmail.com
Wed Jun 29 20:41:34 UTC 2005

On 6/29/05, chris at cpr.homelinux.net <chris at cpr.homelinux.net> wrote:
> On Wed, Jun 29, 2005 at 12:40:12AM +0100, Nick wrote:
> > > Is there a correct way to load the module WAY earlier?  I'm thinking there's
> > > a more correct way to get it to load first.. before any of the /etc/init.d
> > > stuff runs.
> > I run the modprobes (2 cards) and start mythbackend from rc.local (you
> > could prob do it from rc.sysinit too).
> With Debian-based distros, the *proper* way to load a hardware module
> at boot time is to add the module's name to the list in /etc/modules
> and allow the /etc/init.d/module-init-tools script load it at the
> appropriate moment during the boot-up sequence.  The module-init-tools
> script uses modprobe to load each listed module so the dependencies
> would automatically be loaded (assuming depmod ran without errors to
> build the dependency tree).

Running FC and RHEL for my backends/frontends so I don't think that
works for me (prob wrong though). Would be a lot cleaner though! I'd
got everything in rc.local whilst testing, and as it worked, hadn't
looked for alternative solutions for FC backends.


More information about the mythtv-users mailing list