[mythtv-users] How to debug "no sound" ?

John P Poet jppoet at gmail.com
Sun Jun 26 03:20:38 UTC 2005

 I just did a fresh install of Fedora Core 4. Everything is working great, 
except I get no sound out of Myth.

I had a similar problem when I first installed my maudio sound card under 
FC2. All "other" programs would produce sound out the S/PDIF jack just fine, 
but Myth was mute. I thought I had finally figured out what needed to go 
into my asound.conf file, to make Myth happy. I have tried using that exact 
same asound.conf file under FC4, but Myth is still silent.

What is weird, is that mplayer works with the S/PDIF out perfectly, even 
when a asound.conf file does not exist. All I have to do is use "mplayer -ao 
alsa -ac hwac3" and it just works.

Xine and aplay require the asound.conf file, however. For Xine and aplay, 
this asound.conf file is sufficient:

pcm.!default {
type plug
slave.pcm iec958

pcm.ice1712 {
type hw
card 0
device 0

ctl.ice1712 {
type hw
card 0

With the above asound.conf, I can play both AC3 and stereo material via the 
S/PDIF port using any program *except* Myth.

Under FC2, I thought I had solved the problem by adding:

pcm.ice1712_spdif {
type plug
ttable.0.8 1 # S/PDIF left...Delta 9
ttable.1.9 1 # S/PDIF right...Delta 10
slave.pcm ice1712

And then telling Myth to use "ALSA:ice1712_spdif". However, that does not 
seem to be working under FC4. I end up with this in my log:

2005-06-25 21:03:39.653 Using protocol version 17
adding pes stream at pid 0x31 with type 2
adding pes stream at pid 0x34 with type 129
2005-06-25 21:03:42.696 libavformat type mpegts
0: start_time: 4752.137 duration: 323.408
1: start_time: 4752.094 duration: 323.407
stream: start_time: 52801.048 duration: 3593.896 bitrate=15577 kb/s
2005-06-25 21:03:43.472 Stream #1 (audio track #0) is an audio stream with 2 
2005-06-25 21:03:43.472 Auto-selecting AC3 audio track (stream #1).
2005-06-25 21:03:43.472 Initializing audio parms from audio track #0.
2005-06-25 21:03:43.603 Killing AudioOutputDSP
2005-06-25 21:03:43.604 Opening audio device 'ice1712_spdif'.
2005-06-25 21:03:43.612 in SetParameters(format=2, channels=2, rate=48000, 
buffer_time=500000, period_time=125000)
2005-06-25 21:03:43.613 get_buffer_size returned 6553
2005-06-25 21:03:43.613 set_period_time_near returned 68250
2005-06-25 21:03:43.613 get_period_size returned 3276
2005-06-25 21:03:43.621 Audio fragment size: 4096
2005-06-25 21:03:43.623 Audio Stretch Factor: 1
2005-06-25 21:03:43.623 Ending reconfigure
2005-06-25 21:03:43.624 kickoffOutputAudioLoop: pid = 13790
2005-06-25 21:03:43.624 OutputAudioLoop: Play Event

I am not even sure the problem has anything to do with the S/PDIF port. 
Using the envy24control utility, I see that when Myth is "playing", no audio 
is being generated on *any* of the soundcard's jacks. When I use 
mplayer,xine or aplay, the envy24control utility shows me that audio is 
being routed to the S/PDIF jack. If I remove the asound.conf file, and use 
aplay, envy24control shows me that the audio is being routed to the first 
two analog jacks.

So, how do I debug this? How can I figure out why all other programs will 
send sound to my audio card, but Myth is mute? Since Myth is not generating 
any errors, I have no idea where to look.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050625/2039c99f/attachment.htm

More information about the mythtv-users mailing list