[mythtv-users] Playback vid corruption with 1080i (with pics)

gad gad at jetcom.org
Sat Jun 25 14:05:32 UTC 2005

Glen Dragon wrote:

> Quoting john sturgeon <john.sturgeon at gmail.com>:
>> On 6/23/05, Doug Larrick <doug at ties.org> wrote:
>>> Deinterlacing is clearly not working in these pictures.  The stripes 
>>> are
>>> so wide because something (probably your video card) is scaling the
>>> pictures to a resolution less than 1080 lines high.  Double-check you
>>> have deinterlacing enabled, and check the output from 'mythfrontend
>>> --verbose playback'.  Also note that bob deinterlacing is disabled if
>>> you're playing at a speed other than 1x.
>>> -Doug
>> Doug is right on.  That is classic when resizing non-deinterlaced
>> content.  You can also see this problem if your filter chain is in the
>> wrong order, and you resize *before* deinterlacing.  You should always
>> de-interlace prior to resizing.
>> John <><
> Hmm.. I am using kernel deinterlacing.  Or at least thats what I 
> specify in the menu.  I don't have any other exotic filters or 
> anything.  I am playing at a 1x speed (normally) The display is 
> outputing onto a lcd flat panel at 1680x1050, the native resolution of 
> the display.  I have Xorg setup to do this resolution.
> I don't know how I would re-arrange the filter chain. Is this 
> configurable somewhere? I assume that X is doing the scaling from the 
> 1920x1080 to the 1680x1050. Is this correct?  If myth is doing the 
> de-int, it should be taking place before the scaling right?
> I will post the output of -v playback when I get home. Anything else I 
> should enable?

Here a log attached when I tried it the other night.
I tried all of the deinterlacers.  No real difference between any of them

I noticed that it could not use the RTC timing method (due to 
permissions on /dev/rtc), I tried as root, and there was no difference.

I'm also noticed that opengl vsync was not working..  I not sure why 
that is, or what is needed to make it work.

Any suggestions?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mythfe.log
Type: text/x-log
Size: 20264 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20050625/50465b0d/mythfe.bin

More information about the mythtv-users mailing list