[mythtv-users] Audio is killing my myth experience

Nick knowledgejunkie at gmail.com
Fri Jun 24 18:54:47 UTC 2005

On 6/24/05, Chad <masterclc at gmail.com> wrote:
> Hi!
> I have recently posted a thread to the list regarding audio problems,
> but they seem to be more generalized than just that given situation.
> I have 2 capture cards, both WinTV Go cards, so I need 2 audio cards
> to capture from.  The 2 audio cards I have in the system are an SB
> Live, and a C-Media, emu10k1, and cmipci respectively.  My kernel is a
> 2.6.12-r1 with Gentoo patches, as far as Alsa goes, it's basically a
> 2.6.12 kernel.
> I have played with quite a few settings on the card, but have had zero
> luck in getting them both to work and actually capture audio.
> Currently:
> I have the SB-Live as the default audio card (/dev/dsp) and the
> C-Media as the second (/dev/dsp1).  I have audio out working just
> fine, but audio capture via line-in OR mic-in are not working
> correctly.  When I open xawtv, I can watch TV and hear audio just
> fine.  However, when I open myth, and I watch the tuner card
> associated with the /dev/dsp (SB Live) card, I get audio directly from
> the input.  Meaning it's completely off sync because it's not being
> recorded, but rather just passed through from the Line-In to Line-Out.

Sounds like you need to select Line-In as your capture, but need to
mute it. xawtv will probably lose audio, but MythTV should be good.

>  Then, if I switch tuners to the one assoicated with /dev/dsp1
> (C-Media) I get no audio at all.  However, if I start off myth with
> the second tuner by increasing it's priority (or completely removing
> the entry for the first one) then it works just fine...

How is the audio for this card setup at the alsa mixer level? Can you
cat the dsp devices outside of myth successfully?

> Any ideas or suggestions are very welcome.  As noted in my other
> thread, I really don't have a clue on what to do or where to go to
> begin working on this.

Do either (if they are different) of the cards supports the alsa bttv
driver to allow audio to be recorded without requiring the patch cable
from audio out to line/mic in? It they do, it may simplify things.

Maybe posting your modprobe.conf and .asoundrc may reveal possible issues.


More information about the mythtv-users mailing list