[mythtv-users] More problems with non-master backend

PAUL WILLIAMSON pwilliamson at mandtbank.com
Wed Jun 22 14:02:52 UTC 2005

Hi all,

Back again with a question.

I have a master backend with two pvr-250s, which doubles as a 
workroom frontend.  All is working on that.  I've got 3 frontend 
only machines that work fine with every feature.  I also 
have two mediamvp's running mvpmc.  They work great too.
Using .18.1 from atrpms.

I went to add a non-master backend/frontend and followed this:


I must have done something close to right, because mythweb 
can see it (sort of).  Clicking on "Backend Status" I get:

Encoder status:

Encoder 1 is local on mythtvmbe and is not recording.
Encoder 2 is local on mythtvmbe and is not recording.
Encoder 3 is remote on mythtvbe1 (currently not connected).

mythtvbe1 is the machine where I'm trying to get the 
non-master running.  When I try to start up mythbackend, 
I get this in my log:

2005-06-21 10:44:46.453 Failed to init MythContext, exiting.
2005-06-22 09:46:54.686 New DB connection, total: 1
2005-06-22 09:46:54.691 Unable to connect to database!
2005-06-22 09:46:54.693 Driver error was [1/2002]:
QMYSQL3: Unable to connect
Database error was:
Can't connect to local MySQL server through socket
'/var/lib/mysql/mysql.sock' (2)

2005-06-22 09:46:54.695 Failed to init MythContext, exiting.

I don't have mysql running on the non-master, so there's 
no mysql.sock to connect to.  I can run the frontend on the machine 

What do I need to do to the mythbackend startup scripts 
to tell it to connect to a remote mysql installation for mythtv?


More information about the mythtv-users mailing list