[mythtv-users] StreamZap PC remote and CVS LIRC

Evil Barney evilbarney at gmail.com
Mon Jun 20 00:10:14 UTC 2005

Hey All, 

I am stuck on lirc and my streamzap usb remote.  There are some good
posts here and elsewhere (which I'll put here for other's reference
sake), but still no luck.

I'm doing Jarods with this kernel ver:

 2.6.11-1.27_FC3smp with i686

The root of my problem is this, I'm getting an "invalid module format"
error when I try to modprobe lirc_streamzap.  best I can figure, I
might have messed up when I downloaded the source and got the wrong
version.  anyway, at this point, I really need a good way to remove
what I've done with LIRC and follow a supported path for streamzap. 
most of the docs here refer to a .6x version of lirc that requires a
diff patch.  looks like that is not needed in .7x, but not sure.  I've
tried it both ways.

Here is what I've done to get to where I'm at:
1-jarrod lirc stuff :
apt-get install lirc-kmdl-$KVER
# apt-get install lirc 

2--Then  install lirc CVS:

 cvs -d:pserver:anonymous at cvs.sourceforge.net:/cvsroot/lirc login 
(press enter when prompted for password) 
# cvs -z8 -d:pserver:anonymous at cvs.sourceforge.net:/cvsroot/lirc co lirc 

3-then had to get source, I followed this guide:
this site above basically shows how to get kernel source, and install
for the purpose of recompling lirc.  very helpful (if it would have

4 - at this stage, I found my lircd.conf file for streamzap, and moved
that to /etc/lircd.conf.  then I added this line to

alias char-major-61 lirc_streamzap

then, when I tried to do a depmod on lirc_streamzap, I get the
"invalid module format" error.

help!  also, anyone want to go on record about the "diff patch" most
of these lirc sites talk about?

other good source for lirc seakers:



More information about the mythtv-users mailing list