[mythtv-users] DVB, Diseqc and scan

Johan Tufberg tufberg at home.se
Sun Jun 12 12:29:43 UTC 2005

Simon Kenyon wrote:

>On Sunday 12 June 2005 08:46, Johan Tufberg wrote:
>>Simon Kenyon wrote:
>>>On Saturday 11 June 2005 23:34, Johan Tufberg wrote:
>>>>I have a myth box setup with a TechnoTrend premium DVB-S that are
>>>>supposed to communicate with 2 LNB:s on one dish trough a Diseqc switch
>>>>(1.0, 2-way). The satellites I'm trying to use are Thor and Sirius.
>>>>I have entered the transponders and I have also been able to scan the
>>>>satellite on LNB1 but I can not seem to be able to get myth  so select
>>>>LNB2. When I try to scan the second satellite I get, NO LOCK.
>>>>If I switch the cables I get signal locked on LNB1 but still LNB2 seems
>>>>to be non-operating. I've read that there have been reports on this
>>>>listing that there may be some problems with LNB switching via Diseqc?!
>>>>Anyone that can shine some light upon this issue or give any direction
>>>>of where to search for answers...
>>>i cannot get diseqc to work either
>>>this is with 2.6.11
>>>i've used the kernel dvb drivers and the linuxtv cvs
>>>i've asked questions on the linux-dvb list but have never got an answer
>>>from googling around it does appear that there is a bug in the diseqc
>>>surpport (something to do with timing calculations) in the 2.6 version of
>>>the drivers. but nobody seems bothered to fix it and i don't really know
>>>how to.
>>>unless this is all compkete rubbish and i have either a broken nexus-s or
>>>two broken switches.
>>>so all i'm really saying in a very long way is "me too"
>>Simon, I'm also using 2.6.11 kernel drivers on my gentoo system. I have
>>compiled mythtv from source instead of getting it from an ebuild.
>>Anyway, I have also ompiled the linuxtv-apps from linuxtv.org. In this
>>bundling of test utilitys there is a scan utility useful for scanning
>>transponders and getting an output of channels that can be used in vdr.
>>When using the scan utility I can scan both my satellites without any
>>problems and therefore switching between the LNB:s  work. An example
>>"./scan -s 1 dvb-s/THor-1.0W" where the "-s 1" tells the scan utility to
>>use the second LNB and this works without any problems.
>>So what I'm trying to say in a long way is that I do not think it is the
>>kernel drivers that are the issue.
>i agree
>for me scan does not work correctly (or more likely the switch/nesus do not 
>work correctly)
>i've tried two switches, so maybe it is the card in my case
>sorry i couldn't help
>mythtv-users mailing list
>mythtv-users at mythtv.org
No probs simon ;-)..  What linux os are you running? Have you tried the 
linuxtv package and compiled the drivers from their source?!

Anyway, there have to be someone out there who have successfully 
installed  and setup diseqc switching (1.0, 2-way). I've read somewhere 
on these lists that the problems with Diseqc was encountered with the 
0.17 release or I may be wrong in this case?!

I've checked the ouput from mythtv-setup and when I'm using the first 
LNB to scan the transponders I see this command is sent:

"DiSEqC 1.0 Switch - Port 0
DiSEqC Sending 1.0 Command: e0 10 38 f1"

Shortly thereafter I get a lock on the signal. But when i use the second 
videosource, the one that is connected to LNB2, i get the following command:

"DiSEqC 1.0 Switch - Port 1
DiSEqC Sending 1.0 Command: e0 10 38 f4"

and after this I get No Lock. So from this I see that the commands sent 
to the switch may is only different by the last piece "f1" and "f4". Is 
this correct?! I only have two LNB's.


More information about the mythtv-users mailing list