[mythtv-users] splitting audio & video for DVD

Greg Woods greg at gregandeva.net
Sun Jun 12 04:50:58 UTC 2005

I have tried both methods described in the "Installing and Using MythTV"
document, and neither one works. One uses a script like this:


mkfifo aud0
mkfifo vid0
mkfifo dvdmpg

mpeg2desc -a0 < $1 > aud0 &
mpeg2desc -v0 < $1 > vid0 &
mplex -f 8 -V -o dvdmpg aud0 vid0 &
dvdauthor -o $2 -f dvdmpg
dvdauthor -o $2 -T

rm aud0
rm vid0
rm dvdmpg

When I try this, the result is:

DVDAuthor::dvdauthor, version 0.6.10.
Build options: gnugetopt magick iconv freetype fribidi
Send bugs to <dvdauthor-users at lists.sourceforge.net>

INFO: dvdauthor creating VTS
   INFO: [mplex] mplex version 1.6.3-rc1 (2.2.3 $Date: 2004/01/13 20:45:26 $)
STAT: Picking VTS 01

STAT: Processing dvdmpg...
Could not read
**ERROR: [mplex] Unable to read from aud0.

At this point, it hangs. I have to control-C out of it, then kill off the shell 
and mplex processes, and remove the fifo files. It creates the directory and the 
AUDIO_TS and VIDEO_TS subdirectories, but they are empty. The problem is that
"mpeg2desc" doesn't actually work. If I try running one of those commands by
itself, the result is:

$ mpeg2desc -a0  < 1007_20050611160000_20050611163000.nuv > 1.mp2
Could not read

Just that, nothing more helpful. Using -v0 instead of -a0 gives the same result.
It takes about 15 seconds before the error occurs, but the output file is empty.

The second method involves using avidemux2 to split the audio and video. When
I do this, separately save the audio and video, then run:

$ mplex -f 8 -o 1.mpg 1.m2v 1.mp2
   INFO: [mplex] mplex version 1.6.3-rc1 (2.2.3 $Date: 2004/01/13 20:45:26 $)
**ERROR: [mplex] File 1.m2v unrecogniseable!
   INFO: [mplex] File 1.mp2 looks like an MPEG Audio stream.
**ERROR: [mplex] Unrecogniseable file(s)... exiting.

I am fairly sure the problem here is that the 1.m2v file is actually MPEG-4
rather than MPEG-2 which I think it should be:

$ file 1.m2v
1.m2v:     MPEG sequence, v4, video, simple @ L1

How do I get avidemux2 to savee
the video as MPEG-2? Am I doing something else wrong?

Thanks for any help or pointers to web sites or other documentation.


More information about the mythtv-users mailing list