[mythtv-users] Myth, IRBlaster, FC3 and a single instance of LIRC?

jonr jonr at destar.net
Fri Jun 10 02:01:12 UTC 2005

Darren Richards wrote:
> On 4/15/05, Claude Boucher <bouchecl at gmail.com> wrote:
>>Hello everyone,
>>Has anyone had any luck with the "Controlling a digital cable/satellite
>>box using Fedora, MythTV, an IR Blaster and one instance of LIRC". howto
>>(available at http://www.lircsetup.com/lirc/blaster/index.php)?
>>I'm having a hard time replicating such a setup on a myth system running
>>an FC3 installation (done with the most recent version of Jarod Wilson's
>>bible) and I've kept it updated with apt using the atrpms.net (kernel
>>2.6.10_770; lirc 0.70; ivtv 0.32q) repository.
>>There is nothing really exotic in my box (AMD Sempron3000+; Asus
>>A7N8X-VM/400 Mobo with on-board audio and LAN; Hauppauge PVR250 retail
>>with grey and black remote; and the pre-built IRBlaster available at
>>http://www.irblaster.info, Asus-branded FX5200 AGP card) and my system
>>works almost without a glitch under MythTV 0.17.
>>So, I followed the howtos to the letter. After doing all the typing, and
>>after rebooting the system, the only thing I get is a cryptic message:
>>irsend: could not connect to socket
>>I've tried setting my only com port to IRQ 3 / 0x02F8 / ttyS1  and IRQ 4
>>/ 0x03F8 / ttyS0 in the BIOS (with subsequent modifications to
>>/etc/rc.d/rc.local and /etc/modprobe.conf) with no success.
>>Then, I've noticed Jarod's update to his howto
>>(http://wilsonet.com/mythtv/fcmyth.php#lirc) where he applies a diff to
>>/etc/rc.d/rc.sysinit and modifies /etc/udev/rules.d/lirc.rules to force
>>the preloading of some devices, including the infrared drivers. I
>>remember applying this diff. Could it be a factor in my own failure?
>>So, before switching to the methods involving compiling two instances of
>>LIRC (I have absolutely no experience with compiling stuff; I didn't
>>even installed the dev tools...), I'd like to know if anyone had success
>>with the "one instance of LIRC method".
>>Thanks for your advice,
> Yes, I have followed these instructions and I can say that it works
> beautifully.  I have a pvr-350 with remote and two IR blasters
> controlling two Dish satellite receivers, and one instance of LIRC.
> I also repeatedly saw that same error mesage you mentioned.  It was
> because I had specified the wrong com port.  I would *highly*
> recommend setting your modprobe.conf for COM1, REBOOTING, and testing.
>  If that doesn't work, change it to COM2 and REBOOT, and test again. 
> Rebooting each time may sound excessive, but had I given in and done
> just that, I would have saved myself hours of frustration...
> -darren

I too have done this using the same instructions and have it working. 
Another thing you can try is if you have a digital camcorder or a 
digital camera with a LCD screen try this. Send the command to your 
IRBlaster and watch it through the LCD screen and see if you can see it 
emitting a white light. It is hidden to the human eye but the LCD screen 
will pick it up. Mine was working when I thought it wasn't because it 
wouldn't change the channel. I had to move the blaster so it was off 
center of the IR receiver on the cable box before it started working.

Hope that helps,


More information about the mythtv-users mailing list