[mythtv-users] Remote Problem: Need for modifying settings.pro to enable lirc support

ctd at minneapolish3.com ctd at minneapolish3.com
Thu Jun 9 13:11:02 UTC 2005

Need for modifying settings.pro to enable lirc support:

In general I am trying to get my PVR-350 remote to work and have pieced together
info from the mythtv doc and the  http://wilsonet.com/mythtv doc.  

Current system state:
After a system startup, irw works correctly so I know that my remote, VPR-350
card, and lircd are working.  But the remote does not work in mythtv.  My current
line of attack is to ensure that I have my mythtv compiled to support lirc.

I have read various posts on this subject and have some general guestions.

I have seen various posts that mention that mythtv's setting.pro file must be
modified to comment out the following two lines to enable lirc support:
# Native lirc support 
#CONFIG += using_lirc 
#LIRC_LIBS = -llirc_client 

I do not see these lines in my setting.pro (myth0.18.1).  Should these be added
before compiling? Are these posts for an older version of mythtv?

The 0.18.1 documentation states:
"As of MythTV version 0.18, there is no need to edit the settings.pro file to set
compile-time options."
And I see from looking at the configure script that the default for lirce is
true:  lirc="yes"

Later in the lirc section of the myth doc, it then states:
 "Once you know that your remote is working, you can either recompile MythTV with
native lirc support by enabling it in configure ..."

Looking at the outoup of running "configure -h", I do not see how one enables
this support.

So are these any specific steps needed to enable lirc support when compiling mythtv?

Other things that I am in the process of confirming:
1) /home/mythtv/.lircrc and /home/mythtv/.mythtv/lircrc are globally readable and
owned my my mythtv user
2) Try using remote with mplayer, since irw working only proves lircd is working
and not much more.
3) Reconfirm that I am using the correct lircd.conf and lircrc files for the 3rd
generation HG remote.

Thanks for your thoughts.


My Setup:
mythtv 0.18.1
mandrake 10.2
ivitv 0.3.6e
PVR-350 using TV-out (don't have X-windows going to TV just as that is another

More information about the mythtv-users mailing list