[mythtv-users] Re: mplayer audio sync issues

Brian C. Huffman huffman at graze.net
Wed Jun 8 20:48:58 UTC 2005

Discussion about mythtv <mythtv-users at mythtv.org> wrote: 
> ALSA 1.0.9 uses the dmix plugin by default on all soundcards that lack 
> hardware mixing support (previous versions required you to explicitly 
> request dmix).  So, what does this mean?  Well, if you play any audio 
> via an ALSA driver whose soundcard doesn't support hardware mixing and 
> you specify ALSA's "default" device (i.e. aplay -D default 
> /path/to/audio_file or aplay /path/to/audio_file)--and you have *not* 
> redefined the default device--ALSA will automatically enable the dmix 
> plugin (and, since dmix requires a specific type of audio, the plug 
> plugin is used to do automatic conversion).  However, if you specify the 
> "recommended" (i.e. not very useful) .asoundrc--i.e.

Does this require the 1.0.9 kernel modules?  Or just libraries / utilities?  I'm
assuming that running Fedora Core 2, the kernel modules will not be near 1.0.9. 
I'm not even sure I need this, but I'm curious.


More information about the mythtv-users mailing list