[mythtv-users] MythTV 0.18.1 compile problem

Piers Kittel mythtv at biased.org
Wed Jun 8 17:52:57 UTC 2005

Hello all,

Have wiped my MythTV's hard drive to start again, installed Debian 
Sarge, but have not installed X as the box will not be used as a 
frontend (though am worrying how I would run setup without X...).

Anyway, am having a problem with missing libraries, but seem to have 
installed everything that's required, so am tearing my hair out now why 
it's not compiling.  The error is as of:

cd libmyth && make -f Makefile
make[2]: Entering directory `/usr/src/mythtv-0.18.1/libs/libmyth'
rm -f libmyth-0.18.1.so.0.18.1 libmyth-0.18.1.so libmyth-0.18.1.so.0 
g++ -shared -Wl,-soname,libmyth-0.18.1.so.0 -o libmyth-0.18.1.so.0.18.1 
dialogbox.o lcddevice.o mythcontext.o mythwidgets.o oldsettings.o 
remotefile.o settings.o themedmenu.o util.o mythwizard.o uitypes.o 
xmlparse.o mythplugin.o mythdialogs.o audiooutput.o inetcomms.o 
httpcomms.o mythmedia.o uilistbtntype.o uiphoneentry.o generictree.o 
managedlist.o DisplayRes.o volumecontrol.o volumebase.o 
audiooutputbase.o dbsettings.o screensaver.o screensaver-null.o output.o 
langsettings.o mythdbcon.o audiooutputnull.o DisplayResScreen.o 
util-x11.o qmdcodec.o audiooutputoss.o mythcdrom.o mythmediamonitor.o 
mythcdrom-linux.o jsmenu.o jsmenuevent.o moc_dialogbox.o moc_lcddevice.o 
moc_mythcontext.o moc_mythwidgets.o moc_settings.o moc_themedmenu.o 
moc_mythwizard.o moc_uitypes.o moc_mythdialogs.o moc_inetcomms.o 
moc_httpcomms.o moc_mythmedia.o moc_uilistbtntype.o moc_uiphoneentry.o 
moc_managedlist.o moc_mythcdrom.o moc_mythmediamonitor.o moc_jsmenu.o 
-L/usr/share/qt3/lib -L../libmythsamplerate -lmythsamplerate-0.18.1 
-L../libmythsoundtouch -lmythsoundtouch-0.18.1 -lqt-mt -lXext -lX11 -lm 
/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
make[2]: *** [libmyth-0.18.1.so.0.18.1] Error 1
make[2]: Leaving directory `/usr/src/mythtv-0.18.1/libs/libmyth'
make[1]: *** [sub-libmyth] Error 2
make[1]: Leaving directory `/usr/src/mythtv-0.18.1/libs'
make: *** [sub-libs] Error 2

Did a lot of googling, seems that I need the xlib-static-dev and the 
libxext-dev packages but:

mythtv:/usr/src/mythtv-0.18.1# apt-get install xlibs-static-dev libxext-dev
Reading Package Lists... Done
Building Dependency Tree... Done
xlibs-static-dev is already the newest version.
libxext-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Even tried the build-dep thing:

mythtv:/usr/src/mythtv-0.18.1# apt-get build-dep mythtv
Reading Package Lists... Done
Building Dependency Tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I have put in the relevant info in the sources.list file required for 
build-dep to work.

Any ideas anyone?

Thanks very much for your help in advance!

Cheers - Piers

More information about the mythtv-users mailing list