[mythtv-users] Re: A little upgrade help...

PAUL WILLIAMSON pwilliamson at mandtbank.com
Tue Jun 7 11:23:44 UTC 2005

>>> Axel.Thimm at ATrpms.net 06/06/05 2:18 PM >>>
On Mon, Jun 06, 2005 at 12:00:06PM -0400, PAUL WILLIAMSON wrote:
> > After what appeared to be a successful install, grub doesn't give me
> > the option to boot an FC3 kernel.
> How did you upgrade? anaconda? apt-get?

via CDs.  I thought that was the only way to get from FC2 to FC3.
Is that not the right way to do it?

> > This is a combined FE/ master BE.  I've tried doing an apt-get 
> > of libstdc++, but apt-get fails on the same dependencies.
> Are the apt-get sources.list pointing to FC3 repos? If you then try
> apt-get -f install to fix broken dependencies.

I can't because apt-get is broken:

[root at mythtvmbe apt]# apt-get -f install
apt-get: error while loading shared libraries: libstdc++.so.5: cannot 
open shared object file: No such file or directory[

> > The biggest problem is that there are no choices to boot to 
> > an FC3 kernel.  Only the FC2 kernels show up in grob.conf.
> If the kernels *are* installed, boot into an arbitrary kernel and 
> do something like
> /sbin/new-kernel-pkg --package kernel --mkinitrd --depmod 
> --install 2.6.11-1.27_FC3

That doesn't work.  I get:

[root at mythtvmbe apt]# /sbin/new-kernel-pkg --package kernel --mkinitrd
--depmod --install 2.6.11-1.27_FC3
FATAL: Could not open '/boot/System.map-2.6.11-1.27_FC3': No such file
or directory

So, it does not appear as if everything in the upgrade worked.  Go 
to plan B.
The only items in my /boot directory for System-2.6 are:


> The best upgrade procedure is:
> a) backup data
> b) wipe disk
> c) install new distro

This is plan B.

Thanks for the help.  


More information about the mythtv-users mailing list