[mythtv-users] Re: mplayer audio sync issues

Marshall Crocker marshall at iconux.org
Tue Jun 7 02:26:04 UTC 2005

My problems started after I did an update on May 27.  Listed below is my 
yum.log on that day.  I know it was that day because I was watching bsg 
eps the day before and after the update I started having problems.  But 
as I said, its only problems with divx/xvid.  It may be something 
specific to our hardware. What kind of sound card do you have?  I have a 
very old ensoniq audio PCI that came out of an old gateway 2000 pc :) 
lspci for the soundcard produces

00:0a.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
         Subsystem: Ensoniq Creative Sound Blaster AudioPCI64V, AudioPCI128
         Flags: bus master, slow devsel, latency 32, IRQ 6
         I/O ports at b800 [size=64]
         Capabilities: [dc] Power Management version 1

and here is the update log for yum on May 27.  Alsa was updated along 
with mythtv and I installed several packages I was going to need for
my PVR 150 when it came in.  I also installed the alsa-kmdl and 
alsa-driver packages but later removed them because I thought they might 
be the problem but no luck.  I also tried it with the old kernel to no 
avail.  I'm clueless.  Updating alsa tonight and will downgrade if that 
doesn't help.


May 27 01:20:19 Updated: libglib-2.0_0.i386 2.6.4-1_11.rhfc3.at
May 27 01:20:23 Updated: libasound2.i386 1.0.9-19_rc4.rhfc3.at
May 27 01:20:23 Updated: libgthread-2.0_0.i386 2.6.4-1_11.rhfc3.at
May 27 01:20:23 Updated: libgmodule-2.0_0.i386 2.6.4-1_11.rhfc3.at
May 27 01:20:25 Updated: libmyth.i386 0.18.1-111.rhfc3.at
May 27 01:20:29 Updated: mythtv-themes.i386 0.18.1-111.rhfc3.at
May 27 01:20:31 Updated: mythtv.i386 0.18.1-111.rhfc3.at
May 27 01:20:33 Updated: mythtv-frontend.i386 0.18.1-111.rhfc3.at
May 27 01:20:35 Updated: mythgame.i386 0.18.1-109.rhfc3.at
May 27 01:20:41 Updated: mythmusic.i386 0.18.1-109.rhfc3.at
May 27 01:20:44 Updated: mythvideo.i386 0.18.1-109.rhfc3.at
May 27 01:20:47 Updated: mythnews.i386 0.18.1-109.rhfc3.at
May 27 01:20:48 Updated: mythweather.i386 0.18.1-109.rhfc3.at
May 27 01:20:48 Updated: mythgallery.i386 0.18.1-109.rhfc3.at
May 27 01:20:49 Updated: mythbrowser.i386 0.18.1-109.rhfc3.at
May 27 01:20:49 Updated: mythphone.i386 0.18.1-109.rhfc3.at
May 27 01:20:50 Updated: mythdvd.i386 0.18.1-109.rhfc3.at
May 27 01:20:51 Updated: mythtv-backend.i386 0.18.1-111.rhfc3.at
May 27 01:20:54 Updated: libgobject-2.0_0.i386 2.6.4-1_11.rhfc3.at
May 27 01:20:59 Updated: ImageMagick.i386
May 27 01:22:30 Installed: kernel.i686 2.6.11-1.27_FC3
May 27 01:22:32 Updated: alsa-utils.i386 1.0.9-12_rc4a.rhfc3.at
May 27 01:22:33 Updated: mythtv-setup.i386 0.18.1-111.rhfc3.at
May 27 01:22:33 Updated: mythplugins.i386 0.18.1-109.rhfc3.at
May 27 01:22:35 Updated: alsa-lib.i386 1.0.9-19_rc4.rhfc3.at
May 27 01:22:36 Updated: info.i386 4.8-2.1
May 27 01:22:38 Updated: glib2.i386 2.6.4-1_11.rhfc3.at
May 27 01:22:41 Updated: sudo.i386 1.6.7p5-30.2
May 27 09:27:47 Installed: nvidia-graphics7174-kmdl-2.6.11-1.27_FC3.i686 
May 27 13:32:20 Installed: alsa-kmdl-2.6.11-1.27_FC3.i686 
May 27 13:50:25 Installed: alsa-driver.i386 1.0.9-37_rc4a_.rhfc3.at
May 27 13:57:39 Installed: ivtv-firmware-dec.i386 2.02.023-4.at
May 27 13:57:39 Installed: ivtv-firmware-enc.i386 2.04.024-4.at
May 27 13:57:41 Installed: ivtv-kmdl-2.6.11-1.27_FC3.i686 
May 27 14:08:11 Installed: perl-Video-Frequencies.noarch 0.03-2.rhfc3.at
May 27 14:08:11 Installed: perl-Config-IniFiles.noarch 2.38-2.rhfc3.at
May 27 14:08:11 Installed: perl-Video-ivtv.i386 0.13-6.rhfc3.at
May 27 14:08:12 Installed: ivtv.i386 1:0.3.5g-91.rhfc3.at
May 27 14:16:42 Installed: portaudio.i386 18_1-2.rhfc3.at
May 27 14:16:42 Installed: lirc-devices.noarch 0.7.0-1.rhfc3.at
May 27 14:16:46 Installed: lirc.i386 0.7.1-46.rhfc3.at
May 27 14:16:47 Installed: lirc-kmdl-2.6.11-1.27_FC3.i686 0.7.1-46.rhfc3.at

Adam Gianola wrote:
> Thanks Axel for the quick response.  
> It is certainly puzzling, and I only just noticed it the other day, it
> could have started happening when I updated on May 28, though I'm not
> certain.  The old alsa I had been using was 1.0.8, but its wierd in
> that only xvid/avi is affected, and I'm using mplayer within and
> outside of mythtv with identical results, though it looks like mplayer
> hasn't been updated for quite a while.  Nothing in the diff's stick
> out like a sore thumb.  When I get the chance, I'll think about
> switching back to alsa 1.0.8 and report back....
> Thanks again,
> Adam
> On 6/6/05, Axel Thimm <Axel.Thimm at atrpms.net> wrote:
>>On Mon, Jun 06, 2005 at 09:52:09AM -0600, Adam Gianola wrote:
>>>Yes this is exactly the problem, and its been easily corrected for me
>>>with the -delay option.  I also noticed it happened after an 'apt-get
>>>dist-upgrade' and I'm pretty sure alsa was updated then (as well as
>>>most mythtv packages).  The alsa rpms I'm running must be:
>>>alsa-driver-1.0.9rf-39.rhfc3.at and alsa-utils-1.0.9rf-14.rhfc3.at
>>>which look like the current versions on atrpms.  i'm not entirely sure
>>>what the old versions were, but it had been at least 2 weeks or so
>>>since the last dist-upgrade.  I haven't looked at the atrpms list, but
>>>i'm cc'ing this message to that list in the hopes that the right
>>>people notice this and may be able to comment if it is an rpm problem
>>>or not.
>>>FWIW, my mainboard is
>>>SOYO SY-P4RC350 Socket 478 ATI 9100IGP (RS300) Micro ATX Intel Motherboard
>>>with onboard sound
>>>ATI Technologies Inc IXP150 AC'97 Audio Controller
>>>ps. is there a simple way to list the previously installed alsa
>>>packages or downgrade?  my mind is failing me right now...
>>rpm -qa --qf '%{name}-%{version}-%{release}.%{arch}.rpm\n' 2>&1 | sort > /tmp/rpmpkgs
>>ls -ltrA /var/log/rpmpkgs* /tmp/rpmpkgs
>>diff -ud /var/log/rpmpkgs /tmp/rpmpkgs
>>But I can't imagine alsa delaying sound. It has to be an issue with
>>the client application. Perhaps the ABI changed in an incompatible
>>FWIW I don't see (well, hear) any such delays.
>>>On 6/5/05, Marshall Crocker <marshall at iconux.org> wrote:
>>>>I had the exact same problem last week after updating from at-rpms.  A
>>>>number of packages were updated but I noticed that alsa was one of them
>>>>so maybe it's the cause? It seems that only divx/xvid files are the
>>>>problem though.  No problems with any other formats so far.
>>>>I haven't had any luck tracking the problem down but I may downgrade
>>>>alsa and see what effect that has.  Has your alsa recently been updated?
>>>>  If so what were the previous and current versions?
>>>>Adam Gianola wrote:
>>>>>Hey folks,
>>>>>Maybe I'm hallucinating (it is entirely possible), but suddenly when I
>>>>>am watching videos using mplayer in 'watch videos' my audio is out of
>>>>>sync with the video.  If I manually adjust to +0.275s by adding
>>>>>'-delay 0.275' to the mplayer command line, it looks better.  This
>>>>>only seems to happen with videos played using mplayer (xvid avis in
>>>>>particular), but when I watch recorded videos (from pvr 250) they are
>>>>>fine.  This only started happening in the last few days, before this,
>>>>>videos which have the mismatch worked fine.  I'm just curious if
>>>>>anyone else has seen this recently.  I've got a FC3 setup using
>>Axel.Thimm at ATrpms.net
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list