[mythtv-users] Re: A little upgrade help...

Axel Thimm Axel.Thimm at ATrpms.net
Mon Jun 6 18:18:50 UTC 2005

On Mon, Jun 06, 2005 at 12:00:06PM -0400, PAUL WILLIAMSON wrote:
> I know I could probably stay with FC2, but with FC4 right around the
> corner, I thought I'd make the jump to FC3 to be right on the
> trailing edge.
> Currently on .17 and FC2 from ATrpms and Jarod's guide.
> After what appeared to be a successful install, grub doesn't give me
> the option to boot an FC3 kernel.

How did you upgrade? anaconda? apt-get?

> (Enough background...) When the machine comes up it boots ok and
> then just has a blinking cursor in the upper left of the screen.  I
> can alt-2 into a cli screen and log in ok.  MySQL is failing to
> start because of the failed dependencies.  This is somehow totally
> screwing up MythTV (set to boot right into the frontend), which is
> trying to start, but fails.
> This is a combined FE/ master BE.  I've tried doing an apt-get 
> of libstdc++, but apt-get fails on the same dependencies.

Are the apt-get sources.list pointing to FC3 repos? If you then try
apt-get -f install to fix broken dependencies.

> The biggest problem is that there are no choices to boot to 
> an FC3 kernel.  Only the FC2 kernels show up in grob.conf.

If the kernels *are* installed, boot into an arbitrary kernel and do
something like

/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install 2.6.11-1.27_FC3

The best upgrade procedure is:

a) backup data
b) wipe disk
c) install new distro

Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20050606/cf0bc8bd/attachment.pgp

More information about the mythtv-users mailing list