[mythtv-users] RE: mythbrowser compiling error with Qt

Paul mythtv at dsl.pipex.com
Sun Jun 5 09:37:15 UTC 2005

>Hi all, 
>I finally got .18.1 compilied and installed on my system 
>running mandrake 9.2, when I compiling the mythplugins, I have 
>encounter an error on mythbrowser(attached below), by disabling 
>mythbrosers plugin, everything else compiled, installled and working 
>fine. Not that I need to use mythbrowser but it's good to have, does 
>anyone know if it required a newer version of Qt? or a way around/fix 
>it? I have qt 3.1.2 on the system. 

>make[1]: Entering directory 
>g++ -c -pipe -Wall -W -O3 -march=pentiumpro -fomit-frame-pointer 
>-DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I/usr/lib/qt3//mkspecs/default -I. 
>-I/usr/local/include -I/usr/include/kde -I/opt/kde3/include 
>-I/usr/lib/qt3//include -o webpage.o webpage.cpp 
>webpage.cpp: In member function `void WebPage::started(KIO::Job*)': 
>webpage.cpp:201: error: `BusyCursor' is not a member of type `Qt' 
>make[1]: *** [webpage.o] Error 1 
>make[1]: Leaving directory 
>make: *** [sub-mythbrowser] Error 2 


Change 'Qt::BusyCursor' to 'Qt::WaitCursor'
line 201 webpage.cpp

Qt::BusyCursor is only available from qt3.3 onwards.


More information about the mythtv-users mailing list