[mythtv-users] Video Pixelation

Michael T. Dean mtdean at thirdcontact.com
Sun Jul 31 15:41:44 EDT 2005

Jason Lee wrote:

> Michael T. Dean wrote:
>> http://www.gossamer-threads.com/lists/mythtv/users/142484
> Never did occur to me to search the archive.  Doh!  Thanks for 
> pointing to me that, but, unfortunately, it didn't work.  I even tried 
> recreating the entire DB, but that didn't help either.  I guess I'll 
> take this opportunity and upgrade to FC4 and pray that solvesmy 
> problem...

Even after you fix the corrupted table, the problem will persist until 
you rebuild the seektable entries using mythcommflag.

If you deleted the database and recreated it, it may or may not help:  
if you recreated it from a backup of a bad database, it will still be 
broken; if you recreated it with a partial backup (i.e. recorded, 
oldrecorded, and maybe a couple others, you'll have a clean database, 
but you would still get the problem without the recordedmarkup table 

Regardless, you probably have missing or bad entries in recordedmarkup.  
You can rebuild the seektable entries file by file with something like:

mythcommflag --rebuild -f <filename>

or, if you'd prefer to just "punt" (note that this could take several 
days of CPU time to rebuild everything depending on quantity) delete the 
rows from recordedmarkup (i.e. "truncate table recordedmarkup") when 
you're not recording anything, then

mythcommflag --all

I would recommend testing one program--verify that it shows the macro 
blocks when you seek forward, then use mythcommflag to rebuild only that 
file's seektable entries, and test to see if it clears up the problem.

If not, do you by any chance have "Seek to exact frame" enabled?  I 
could see that causing a problem like this, but it's possible the devs 
have programmed around that possibility (depending on how much "slower" 
seek to exact frame is).


More information about the mythtv-users mailing list