[mythtv-users] XvMC output not working

David ellis david at ellisonline.ca
Sat Jul 30 20:46:27 EDT 2005

Its funny, I've spent most of the day trying to get this to work  
properly, succeeded (briefly) - only to find intermittent failures.

AMD64 3200, with 1GB of RAM
NVidia 5200
HD3000 using DVB drivers

MythTV 18.1
Nvidia .7667
Gentoo Linux with gentoo-sources 2.6.12-r4

I can get acceptable HD playback with real time threads - but real  
time threads crashes the program guide if I try and change a channel.
XVMC will work (sometimes) - but it is really random.

Nvidia has a open bug for this (it is a driver bug) - but .7667 was  
supposed to be the fix.

Anyone who has this working - What Video card are you using? (maybe I  
could just upgrade/downgrade the video).

On 30-Jul-05, at 7:50 PM, Michael Haan wrote:

> On 7/30/05, Chad <masterclc at gmail.com> wrote:
>> On 7/30/05, Dave <dbadia at gmail.com> wrote:
>>> On 7/30/05, Todd Ignasiak <ignasiak at gmail.com> wrote:
>>>> I just got through rebuilding my system using Gentoo  
>>>> x86-64.      In
>>>> that new configuration, I began having XvMC problems.
>>>> In my current config, XvMC will work if I run mythfrontend as root.
>>>> So, I apparently have a permissions problem.     You might give  
>>>> that a
>>>> try.. I get the same error message you listed when I run as a  
>>>> normal
>>>> user.
>>> Well, I tried the 7667 drivers, and I tried running the frontend as
>>> root, but I'm still getting the errors.
>>> Seems strange that running as root works for you but not me,  
>>> maybe I'm
>>> missing something?
>>> Thanks
>>> Dave
>>> _______________________________________________
>> I was having quite the problem with this too.  I am running High Def,
>> so I really worked diligently to get this going.  I have an AMD64
>> 3200, and nvidia GF4 440MX
>> I finally got it running with the latest drivers (7667).  I did have
>> to recompile myth a couple times while toying with different  
>> versions,
>> myth builds against the installed version.
>> Good Luck!
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> For what it's worth, my experience is similar to Dave's.  I've not yet
> tried 7667.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list