Mythbackend looks in wrong directory for icons (was Re: [mythtv-users] Matching up tv_grab_uk_rt to DVB-T channels)

John Winters john at
Thu Jul 28 03:31:52 EDT 2005

On Thu, 2005-07-28 at 00:19 +0100, Duncan Brown wrote:
> John Winters wrote:
> >One oddity though.  As indicated, I downloaded the icons as well and
> >installed them under:
> >
> >/usr/share/mythtv/icons/tv
> >
> >which is where the sql seems to want them.  They haven't appeared
> >anywhere, but since the database was updated, MythBackend keeps logging
> >a failure to find them, but it's looking for them in:
> >
> >/mirror/video
> >
> >which is where the recordings go.  It seems to be ignoring the path in
> >each channel entry, seizing just the file name and tagging /mirror/video
> >on the front.  Is this another setting somewhere?
> >
> >2005-07-27 17:52:17.374 Could not open /mirror/video/itv1.gif
> >
> >and yet the relevant channel entry contains:
> >
> >/usr/share/mythtv/icons/tv/itv1.gif
> >
> >  
> >
> How odd.. I cant find any other references to icons anywhere in the 
> settings, does the correct entry actually show up in the channel editor? 

Yes.  Looking at the channel record with the channel editor it shows the
icon file name as:


Similarly, looking at the entry directly with mysql shows the same.
However each time an attempt is made to access the icon by my front end
the access fails and mythbackend logs:

2005-07-27 17:52:17.374 Could not open /mirror/video/itv1.gif

It's possible of course that it's the log message which is wrong, but
the icon file is definitely where the database entry says it is.  Anyone
know why mythbackend is looking in the wrong place?


More information about the mythtv-users mailing list