[mythtv-users] apt-get dist-upgrade removes apt-get

Michael Jones m_g_j at michaelandholly.com
Wed Jul 27 20:47:37 EDT 2005


I feel your pain.. I went through the same thing. I must have reloaded 6-7
times before getting it right (on a P3500 frontend that took about an hour
each time.. )

Axel posted some information on the apt-get user group that was helpful - at
least in my case. It seems that the current problem is that the kickstart
files get removed without being replaced (or replaced correctly) and a
library or two gets corrupted so it kills RPM as well in the process (at
least on my machine)

The solution seems to be to manually replace them BEFORE You do a "apt-get
dist-upgrade" command.

The command sequence was:

# apt-get update
# apt-get install rpm librpm4.4 apt atrpms-package-config fedora-release
# apt-get dist-upgrade.

Helped in my case.. it upgrades the apt and rpm packages as well as some of
the library stuff manually..   After which, I ran the dist-upgrade and
everything was OK.   I've heard from some that this didn't do the trick..

- Michael

> From: Nicholas Gibson <ngibsonn at yahoo.com>
> Reply-To: Discussion about mythtv <mythtv-users at mythtv.org>
> Date: Mon, 25 Jul 2005 21:44:01 -0700 (PDT)
> To: <mythtv-users at mythtv.org>
> Subject: [mythtv-users] apt-get dist-upgrade removes apt-get
> Hello,
> I know this problem has been encountered and a
> solution exists somewhere.   If someone could point me
> in the right direction I would greatly appreciate it,
> I'm going to go blind if I install my machine again :)
> I'm following Jarod's howto on a clean FC3 machine.
> Running apt-get dist-upgrade wants to remove, rpm,
> apt-get among other packages.  This leaves me unable
> to continue after performing the apt-get dist-upgrade.
>  Without the apt-get or rpm packages on my system I'm
> essentially dead in the water...
> Any information on how to get around this would be
> greatly appreciated.
> I have attached the output from apt-get dist-upgrade.
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Calculating Upgrade... Done
> The following packages will be upgraded
>   HelixPlayer MyODBC NetworkManager Omni Omni-foomatic
> acl alsa-lib
>   alsa-lib-devel alsa-utils apr arts at autoconf
> autofs automake automake14
>   automake15 automake16 automake17 bash beecrypt
> bind-libs bind-utils binutils
>   boost boost-devel bzip2 bzip2-devel bzip2-libs
> checkpolicy cpp cups
>   cups-libs curl curl-devel cvs dbus dbus-devel
> dbus-glib dbus-python dbus-x11
>   dhclient dhcpv6_client diffstat diskdumputils dmraid
> docbook-dtds dovecot
>   dump e2fsprogs e2fsprogs-devel elinks emacs
> emacs-common emacs-leim enscript
>   ethereal fedora-release fetchmail file flac
> fontconfig fontconfig-devel
>   fonts-xorg-100dpi fonts-xorg-75dpi fonts-xorg-base
> foomatic freeglut
>   freetype freetype-devel gail gamin gamin-devel gcc
> gcc-c++ gcc-g77 gcc-java
>   gd gd-devel gdb gdk-pixbuf glib2 glibc glibc-common
> glibc-devel
>   glibc-headers gnome-vfs2 gnupg gphoto2 grep
> gstreamer gtk2 gzip hal hotplug
>   howl htdig httpd httpd-manual httpd-suexec
> iiimf-libs iiimf-libs-devel info
>   initscripts ipsec-tools iptables jwhois kdeartwork
> kdebase kdegraphics
>   kdelibs kdenetwork kdepim kdeutils kernel-utils
> krb5-devel krb5-libs
>   krb5-workstation lftp libacl libacl-devel libao
> libdv libexif libf2c libgcc
>   libgcj libgcj-devel libgcrypt libgpg-error libogg
> libogg-devel libpcap
>   libpng libpng-devel libpng10 libpng10-devel
> libraw1394 libselinux
>   libselinux-devel libstdc++ libstdc++-devel libtiff
> libtiff-devel libtool
>   libtool-libs libvorbis libvorbis-devel libxml2
> libxml2-devel libxml2-python
>   libxslt lm_sensors lockdev lockdev-devel logwatch
> lsof man mgetty mikmod
>   mod_python mod_ssl module-init-tools mutt mysql
> mysql-devel net-snmp
>   net-snmp-libs net-tools netpbm netpbm-devel
> nfs-utils nscd openjade
>   openmotif openmotif-devel openssh openssh-askpass
> openssh-askpass-gnome
>   openssh-clients openssh-server openssl openssl-devel
> pam pam-devel pcmcia-cs
>   perl perl-Convert-ASN1 perl-HTML-Parser
> perl-XML-LibXML perl-XML-Parser
>   perl-XML-Twig perl-libwww-perl php php-ldap php-pear
> pkgconfig
>   policycoreutils popt postgresql-libs prelink procps
> pygtk2 pygtk2-libglade
>   python python-devel pyxf86config qt redhat-menus
> rhgb rhnlib rhpl rmt
>   rpm-devel rsh samba samba-client samba-common
> sane-backends
>   selinux-policy-targeted sgml-common shadow-utils
> slang slang-devel
>   sound-juicer spamassassin squid sudo sysklogd
> system-config-date
>   system-config-display system-config-printer
> system-config-printer-gui
>   system-config-samba system-config-securitylevel
>   system-config-securitylevel-tui
> system-config-services tcl tcpdump tcsh
>   telnet texinfo tk tzdata udev urw-fonts util-linux
> vim-common vim-enhanced
>   vim-minimal vixie-cron vte wireless-tools words
> xloadimage xml-common
>   xorg-x11 xorg-x11-Mesa-libGL xorg-x11-Mesa-libGLU
> xorg-x11-deprecated-libs
>   xorg-x11-deprecated-libs-devel xorg-x11-devel
> xorg-x11-font-utils
>   xorg-x11-libs xorg-x11-tools xorg-x11-twm
> xorg-x11-xauth xorg-x11-xdm
>   xorg-x11-xfs zip zlib zlib-devel
> The following packages will be REPLACED:
>   howl-libs (by howl)  rpm-libs (by librpm4.4,
> librpm4.3)
> The following packages will be REMOVED:
>   atrpms-kickstart firstboot gstreamer-plugins
> kdeaddons kdemultimedia
>   rhn-applet rhythmbox rpm rpm-build rpm-python
> system-config-network
>   system-config-network-tui system-config-packages
> up2date up2date-gnome
>   vorbis-tools yum
> The following NEW packages will be installed:
>   atrpms docbook-style-dsssl elfutils-devel
> elfutils-libelf-devel
>   fedora-package-config kernel#2.6.11-1.35_FC3
> libFLAC++4 libFLAC6
>   libOggFLAC++0 libOggFLAC1 libbeecrypt6 libdv4
> libfontconfig1 libfreetype6
>   libgcrypt11 libghttp libhowl-0.9.6_1 libhowl0
> libidn-devel libmDNSResponder0
>   libogg0 libosp4 libraw1394_5 libraw1394_8 librpm4.3
> librpm4.4 libttf2
>   libvorbis0 libvorbisenc2 libvorbisfile3 libxslt1
> neon-devel perl-HTTP-GHTTP
>   perl-XML-XPath pythonabi sqlite sqlite-devel
> The following packages have been kept back
>   system-config-users
> WARNING: The following essential packages will be
> removed
> This should NOT be done unless you know exactly what
> you are doing!
>   rpm
> 272 upgraded, 37 newly installed, 2 replaced, 17
> removed and 1 not upgraded.
> Need to get 413MB of archives.
> After unpacking 16.2MB of additional disk space will
> be used.
> You are about to do something potentially harmful
> To continue type in the phrase 'Yes, do as I say!'
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list