[mythtv-users] Newbie getting to know mythtv (long)

Torbjørn Heltne torbjorn.heltne at amelektronikk.no
Mon Jul 25 10:57:48 EDT 2005

Hello everybody!


It is pretty hard to decide which MB, case etc to buy. In the meantime I 
want to familiarize myself with MythTV, so I have installed the other HW 
(pvr-350,DVD-burner/hard disk) in a somewhat retired workhorse (P3/500 

 From what I understand that should be plenty horsepower to run MythTV 
because of the pvr-350. Right?

I have used Linux for years for a number of different, mostly server 
related, purposes both around the house and at the office. I have not 
played with that many different distributions, mostly RH and Fedora and 
also a little bit Debian.

I am going to use the Myth-PC in a set-top setup where it will be 
connected between the existing cable TV in the building and an ordinary TV.

I have read Jarod's guide for installation on FC3 while trying to 
install - but I used FC4 as base.
(Side note: After reading Jarod's step-by-step guide the first time I 
tried to follow it. It went well for a *short* while until I did the 
first apt-get update && apt-get dist-upgrade. After finishing, 
"everything" was broken. The apt-tools had disappeared and even rpm 
barfed when used. I decided that continuing with a questionable base 
linux install would probably not be a good idea. When using FC4 that 
problem disappeared.)


Right now all is installed and I have tried to configure according to 
Jarod's descriptions. I have also borrowed xorg.conf files from others 
on the 'net, therefore I have managed to get KDE and also mythfrontend 
on the TV-screen. First I want to get the DVD player up and running. So 
far I have had no luck. After a number of lines about the DVD itself I get:

DVD successfully opened.
MPEG-PS file format detected.
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  9800.0 kbps (1225.0 kbyte/s)
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Cannot find codec 'dts' in libavcodec...
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
No accelerated IMDCT transform found
hwac3: switched to DTS, 768000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, ac3, 768.0 kbit/50.00% (ratio: 96000->192000)
Selected audio codec: [hwdts] afm:hwac3 (DTS through S/PDIF)
vo: X11 running at 720x576 with depth 24 and 32 bpp (":0.0" => local 
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
Checking audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/ac3...
AF_pre: 48000Hz/2ch/ac3
alsa-init: 1 soundcard found, using: iec958:{CARD 0 AES0 0x02 AES1 0x82 
AES2 0x00 AES3 0x02}
ALSA lib setup.c:549:(add_elem) Cannot obtain info for CTL elem 
(PCM,'IEC958 Playback PCM Stream',0,0,0): No such file or directory
alsa-init: playback open error: No such file or directory
audio_out: alsa9 and alsa1x modules were removed, use -ao alsa instead.

Based on this printout I have tried to find some useful information on 
the 'net, but I'm a bit too unfamiliar with audio/video tools on computers.

All and any helt will be appreciated.

Torbjørn Heltne

More information about the mythtv-users mailing list