[mythtv-users] Strange playback problems - no commercial skipping, random jumps

Ramzy Darwish ramzy.darwish at gmail.com
Fri Jul 22 15:11:11 EDT 2005

Hello All,
I tried looking for others with this problem on the list, but didn't
see anything, but maybe I didn't use the right keywords, so please
don't flame me if this is a common problem.

My main mythbox was working beautifully for quite a long time. Even
after upgrading to 0.18.1, it worked well for a while (after
reconfiguring my nvidia drivers a little bit) and everything was going

So, since evertything was great, I started configuring my other
backend/frontend + a new frontend only epia m10000. I got them both
working and the new backend was able to stream recordings from the
master and do commercial detection and all that great stuff.

So, the next thing I did was start playing with the recording profiles
to compress stuff. I use a pvr350 and started transcoding from mpeg2
to mpeg4.

I don't know if that is what caused the problem, but since I started
that, I get very strange problems in recorded programs. Commercial
skipping will not work, and it won't even bring up an OSD when I
choose "Notify...".

I do have commercial detection jobs running to completion on both the
master and slave backend as reported in the logs and through mythweb
but I cannot see the cutlist from within myth. If I press "Edit
recording" nothing happens. Also, i cannot correctly skip around in
the recording.

Pressing skip ahead, will pause the recording for a few seconds, and
then it may skip 30 seconds ahead. SOmetimes though, it will just get
stuck. no matter what I press, it will not move forward into the
recording. And, when it acts like this, and it shows the OSD for
skipping in the recording, the end time, or total time for the
recording will keep moving up and down by a few seconds as if it is
having trouble finding the total length of the recording.

Then, to make matters worse, it randomly jumps sometimes, just by a
few seconds in the recording. It doesn't bring up an OSD as if it
thinks it is ata commercial, it just jumps around.

Lastly, it takes the system a REALLY long time (sometimes like 10
minutes) to start playing back a recorded program. The screen will go
black and the machine is working, but it takes a long time. But if I
exit the recording then start it again, it comes back quickly, but
none of the other problems are changed.

One thing I noticed, (I am not a hardware person) is that the actual
plug on the pvr350 where you connect the cable is jiggly. Like you can
move it around. I took the card out, and there doesn't seem to be
anything physically broken on the card, but I can't see inside the
little tuner box on the card. I don't know if maybe the signal coming
into the card is faulty from this 'jiggliness'.

I have tried all that I can think of: turned off commercial detection,
then turned it back on; turned off transcoding, tried "notify..."
instead of "Skip..." for commercial skip method.

It doesn't seem to matter what amount of compression/bitrate setting I
use. (I had it kind of low for a while).

While I don't think it matters, my machine is:
Dual PIII 1000Mhz
1G DDR RAM 2700
~120G hard drive set aside for myth recordings
all drives are using LVM
card: pvr350 w/ivtv-0.2.0-rc3j
uname -a: Linux frontend1 2.6.10-gentoo-r6 #6 Sat Mar 26 17:18:25 CST
2005 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux

There is one backend running fedora core 3 from jarod's excellent
guide and the frontend (which I have not really used) is also running

I don't know what else to tell you. I love my mythbox and scaring my
girlfriend with all of the great stuff it can do. I hope my card is
not ruined cuz it's not that old and I hate to chuck stuff that can be
fixed. I can solder if anyone knows what I should look for inside that
thing if they think that is the problem.

I hope I have given you enough information to help me. Help me
mythtv-users, you're my only hope.


More information about the mythtv-users mailing list