[mythtv-users] OpenGL vsync

Joe Votour joevph at yahoo.com
Wed Jul 20 11:31:38 EDT 2005

If OpenGL VSync is working, then the video timing
method should be listed as SGI OpenGL.  Since it is
listed as RTC, you are not using OpenGL VSync.

However, what you've pasted from the logs indicates
that the OpenGL VSync checking code is failing.  Thus,
it appears you have it enabled in the frontend, but
your card or driver doesn't support it.

What type of video card do you have, and which driver
are you running?  As a point of reference, I am using
a GeForce 5200FX card with the nVidia driver version
7174, and OpenGL VSync is working just fine.

Are you using an nVidia card and nVidia driver? 
OpenGL VSync might not work with other cards (i.e.
ATI), and probably won't work any driver but the
binary/proprietary nVidia one.

-- Joe

--- Sammo <sammo2828 at gmail.com> wrote:

> I compiled mythtv with --enable-opengl-vsync
> How do I validate that it is actually using opengl
> vsync?
> Does the following have anything to do with it?
> mythfrontend -v playback >log.txt
> nVidiaVideoSync: Could not open device /dev/nvidia0,
> No such device or address
> DRMVideoSync: VBlank ioctl did not work,
> unimplemented in this driver?
> Using audio as timebase
> Video timing method: RTC
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the mythtv-users mailing list