[mythtv-users] DVB not supported in kernel - but it is!?

Andrew Hall temp02 at bluereef.com.au
Tue Jul 19 03:12:11 EDT 2005

I need help. I'm missing something fundamentally simple here and I'm hoping someone can tell me what I'm doing wrong.

I'm trying to setup Myth 0.18.1 with an Avermedia 771 card under Gentoo. Everything seems to be installed correctly and as far as the kernel ( is concerned, everything seems to be found correctly for DVB support:

Linux video capture interface: v1.00
bttv: driver version 0.9.15 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
bttv0: Bt878 (rev 17) at 0000:00:0b.0, irq: 11, latency: 32, mmio: 0xe7002000
bttv0: detected: AVermedia AverTV DVB-T 771 [card=123], PCI subsystem ID is 1461:0771
bttv0: using: AVerMedia AVerTV DVB-T 771 [card=123,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=0090000f [init]
bttv0: using tuner=4
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: add subdevice "remote0"
bttv0: add subdevice "dvb0"
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6320,tea6420,tda8425,pic16c54 (PV951),ta8874z
ir-kbd-gpio: bttv IR (card=123) detected at pci-0000:00:0b.0/ir0
cx2388x v4l2 driver version 0.0.4 loaded
cx2388x blackbird driver version 0.0.4 loaded
cx2388x dvb driver version 0.0.4 loaded
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:00:0b.1[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
bt878(0): Bt878 (rev 17) at 00:0b.1, irq: 11, latency: 32, memory: 0xe7000000
DVB: registering new adapter (bttv0).
DVB: registering frontend 0 (Zarlink MT352 DVB-T)...

Everything that I need is compiled into the kernel, there are no modules to load.

Gentoo uses udev which doesn't seem to create the requisite /dev/dvb/adaptor directories, so I manually created them with the DVB makenod script, and the following have been created:

localhost ~ # ls -la /dev/dvb/adapter0/
total 0
drwxr-xr-x  2 root root     200 Jul 19 21:44 .
drwxr-xr-x  6 root root     120 Jul 19 21:44 ..
crw-rw----  1 root video 212, 1 Jul 19 21:44 audio0
crw-rw----  1 root video 212, 6 Jul 19 21:44 ca0
crw-rw----  1 root video 212, 4 Jul 19 21:44 demux0
crw-rw----  1 root video 212, 5 Jul 19 21:44 dvr0
crw-rw----  1 root video 212, 3 Jul 19 21:44 frontend0
crw-rw----  1 root video 212, 7 Jul 19 21:44 net0
crw-rw----  1 root video 212, 8 Jul 19 21:44 osd0
crw-rw----  1 root video 212, 0 Jul 19 21:44 video0

My problem, is that within 'mythtv-setup', the card setup doesn't find any DVB cards and I get a 'recompile with DVB support' error in the page. V4L seems to find the composite and S-video inputs fine, but the DVB support fails to find the Avermedia card. I'm assuming (maybe wrongly), that Myth should just find the DVB card as device 0 and then I should be able to scan for channels?

Any help would be most appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050719/188763f7/attachment.htm

More information about the mythtv-users mailing list