[mythtv-users] multiple tuners - configuring capture cards

Mark Knecht markknecht at gmail.com
Tue Jul 12 23:26:32 EDT 2005

On 12 Jul 2005 20:06:47 -0700, Jim Reith <reith at racores.com> wrote:
> >On 12 Jul 2005 19:29:20 -0700, Jim Reith <reith at racores.com> wrote:
> >>  >  > So is that the old or the new format??
> >>  >
> >>  >Old format:
> >>  >
> >>  >options saa7127 i2c_enable=-1,1
> >>  >options cx25840 i2c_enable=1,-1
> >>  >options msp3400 once=1 simple=1
> >>  >
> >>  >Try commenting these out and see what happens.
> >>
> >>  Well, i needed to put them in to clean up dmesg since I have a
> >>  pvr-350 as well as a pvr-150. What would be the new format way to
> >>  tell it about the two modules options? Should it properly auto detect
> >>  those params also?
> >
> >Yes, I sort of understood that, or thought I did. However I think
> >there's some sort of format problem here. Try running
> >
> >modinfo saa7127
> >
> >and see what it really supports. The output of modinfo is anything
> >except friendly to non-programmer types. I hope it's readable to you.
> 30 years of sw dev here. it tells you what the params are but not the
> specific syntax...
> >Anyway, it should tell you what this particular module supports.
> >
> >Cheers,
> >Mark
> Thanks for putting in the time tonight. I commented out those lines
> and did a cold boot and it's up and the remote is back to working!
> Here's the ivtv section of dmesg now. Still complaining about
> obsolete params on the pvr-350 initialization...
> The only thing left then is to get my pvr-350 tv-out back working
> with X. maybe that will magically work again now that the cards seem
> properly functional... That will be left for tomorrow after I take my
> wife off to the airport. She's packing the the bedroom where the tv
> and box are at the moment so I'd best quit and stay out of her way
> ivtv: ==================== START INIT IVTV ====================
> ivtv: version 0.3.6 (y) loading
> ivtv: Linux version: SMP preempt 586 gcc-3.3
> ivtv: In case of problems please include the debug info
> ivtv: between the START INIT IVTV and END INIT IVTV lines when
> ivtv: mailing the ivtv-devel mailinglist.
> ivtv: Autodetected WinTV PVR 150 card


> ivtv: Initialized WinTV PVR 150, card #0
> ivtv: Autodetected WinTV PVR 350 card
> ivtv: Found an iTVC15 based chip


> cx25840: starting probe for adapter ivtv i2c driver #1 (0x10005)
> cx25840: detecting cx25840 client on address 0x88
> cx25840: cx25840 not found

The above looks a bit suspect....

> ivtv: Tuner Type 47, Tuner formats 0x00001000, Radio: yes, Model
> 0x00ad1598, Revision 0x00000001
> ivtv: Radio detected

And below might imply (really jsut guessing ehre though...) that
there's still somewhere that's setting the parameters. Does this
distro do one of those automated things like Suse where it takes the
files you edit and makes the file it really uses? Is it possible that
some file in the config section has a second copy of the options it
doesn't like?

> saa7127: Ignoring new-style parameters in presence of obsolete ones
> saa7127: video encoder driver version V 0.3 loaded


> ivtv: Initialized WinTV PVR 350, card #1
> ivtv: ====================  END INIT IVTV  ====================


More information about the mythtv-users mailing list