[mythtv-users] MySQL errors, mysqld.sock

Aaron Stewart acs at hourglassone.com
Thu Jul 7 19:34:14 EDT 2005

Look in /var/log/mysql/* and see if that points to problems.

I've had a similar issue, but it was one of those things I just blew
through without thinking about what it was, so I'm crossing my fingers
that it's something simple.


al wrote:

>Long time reader, first time poster.
>Problem: MySQL no longer connects to the mysqld server.
>History: I setup a Knoppmyth frontend/backend system (see specs in
>sig, rather vanilla setup) about a year ago. Recently I started over
>from scratch on Gentoo to learn more about the system.
>After installing everything, I had a working MythTV frontend/backend
>system. However, it took me a few weeks to get the IR blaster working.
>The first time I tried MythTV after fixing the IR blaster, mythbackend
>failed. I traced the problem back to MySQL. I could no longer connect
>to the mysqld server or databases.
>I've read up on MySQL troubleshooting but have not found success with
>the common suggestions. I have verified all permissions on the
>applicable directories (/var/lib/mysql, /var/run/mysqld, etc). I have
>a "mysql" user and "mysql" group. I do not have a mysqld.sock, which I
>understand is created upon running the server. I can't create it. I
>have verified that the mysqld.sock is not in /tmp. I've tried
>unmerging/ re-emerging MySQL several times, even upgrading to MySQL
>here is some applicable info about my problem:
># mysqladmin -u root password new-password
>mysqladmin: connect to server at 'localhost' failed
>error: 'Can't connect to local MySQL server through socket
>'/var/run/mysqld/mysqld.sock' (2)'
>Check that mysqld is running and that the socket:
>'/var/run/mysqld/mysqld.sock' exists!
># ps aux | grep mysqld
>root     28316  0.0  0.1   1484   436 pts/0    R+   19:03   0:00 grep mysqld
># mysqld_safe
>Starting mysqld daemon with databases from /var/lib/mysql
>STOPPING server from pid file /var/run/mysqld/mysqld.pid
>050707 18:57:12  mysqld ended
>Can anyone help me? Since this is a new installation, I have no
>database to save. I can destroy/create new databases as needed.
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list