[mythtv-users] Mounting a DVD iso image - There must be an easierway?

Edward Rosinzonsky ed at entetel.com
Thu Jul 7 18:12:33 EDT 2005

Try: xine -pfhq --no-splash dvd://%s/

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Michael Jones
Sent: Thursday, July 07, 2005 2:39 PM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] Mounting a DVD iso image - There must be an

I have an archive of ISO files sitting on a server mounted NFS to my MythTV
backend.  Each ISO file is in its own directory.

MythTV sees the iso files within their folder but when I attempt to
mount/watch the DVD xine flashes a dialog:

xine engine error

There is no demuxer plugin available to handle

Usually this means that the file format was not recognized

.. the same one as when you try to open the file directly in xine through
it's menus This message only appears for a couple seconds and then goes back
to the description of the video.

What I've tried so far:

added the .iso and .ISO extensions to the file types

set the player settings Default player to: 'xine -pfhq --no-splash dvd: %s'
or 'xine -pfhq --no-splash %s' or 'xine -pfhq --nosplash %s/'

none of these options has worked.

The only thing that has worked is mounting the ISO manually:

mount -o loop -t udf path/imagename.iso /mnt/dvd_image

then playing with the 'Play Dvd' command:

xine -pfhq --no/splash /mnt/dvd_image

It seems like the normal methods don't try to mount the image automatically.

Could there be some command or setting missing?  I'm using FC3 if that makes
a difference.

- Michael

More information about the mythtv-users mailing list