[mythtv-users] Need help with Air2pc setup

Byron Poland wpoland at gmail.com
Mon Feb 28 20:44:57 UTC 2005


I'm trying to set up an Air2pc card and mythtv in my Ubuntu Hoary
amd64 machine. Ubuntu has mythtv .17 debs available in its repository,
and they seem to work for me. I've successfully downloaded the cvs dvb
kernel drivers and incorporated them into my kernel and they seem to

   byron at glide:~$ dmesg | grep dvb
   drivers/media/dvb/b2c2/skystar2.c: FlexCopIIB(rev.195) chip found
   drivers/media/dvb/b2c2/skystar2.c: the chip has 38 hardware filters
   nxt2002: Waiting for firmware upload (dvb-fe-nxt2002.fw)...

The air2pc-howto.html showed a reference to a saa7115 module loading,
I didn't have this on my system, did a little googling, and saw it was
included with the ivtv driver, so I compiled that and loaded the
saa7115 module by hand:

   byron at glide:~$ dmesg | grep saa
   saa7115: starting probe for adapter SkyStar2 (0x10000)
   saa7115: starting probe for adapter SMBus Via Pro adapter at 5000 (0x0)
I compiled the dvb-apps from cvs (they crapped out at the
ttusb_dec_reset stuff, so i just took that out of the make file).

Set up the azap stuff, and I get output like this:
byron at glide:~/downloads/dvb-apps/util/szap$ ./azap wpvi
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'

   tuning to 773000000 Hz
   video pid 0x0000, audio pid 0x0000
   status 00 | signal fff0 | snr ea60 | ber 00000000 | unc 00000000 |
   status 1f | signal f5f0 | snr cfe6 | ber 00000598 | unc 00000000 |
   status 1f | signal f580 | snr c27c | ber 00004d48 | unc 00000000 |
   status 00 | signal 8f30 | snr 5a44 | ber 00000000 | unc 00000000 |
   status 1f | signal f930 | snr d27a | ber 00000070 | unc 00000000 |
   status 00 | signal ae60 | snr 5d90 | ber 00000000 | unc 00000000 |

Now when I run mythtv-setup and set up the capture device (following
the air2pc-howto) dvb0  detected:

   DVB Card Number:       0
   Card Name:      Could not get card infor for card #0!
   Card Type:           Success

This is the first place things seem to diverge from the howto.  Of
concern is not getting the card info, and the contradictory: Success.

The next place I get stuck is adding the transports for each channel
as in the mythdvb patchset howto, and there all I can manage to do is
add a Transport ATSC type, and it just defaults to 0 (0,0,0) I think. 
I have no place to enter a channel number or other info.  For fun I
found where this info was stored in the database and manually entered
the frequency and modulation I got from my channels.conf  which works
with azap.  doing a scan of existing transports just times out at each
of the frequencies.

As a last resort I did try to download mythtv cvs, and that just fails
compilation with in libavcodec because of -march=k8 or something.

If anyone has any thoughts or could lead me in a particular direction
I'd appreciate it.


More information about the mythtv-users mailing list