[mythtv-users] Mythweb themes question

Justin Walther justin.walther at gmail.com
Mon Feb 28 19:31:40 UTC 2005

I don't know if my phone is auto-detected or not but here is the log entry: - - [28/Feb/2005:14:26:50 -0500] "GET /mythweb/
HTTP/1.1" 304 - "-" "Mozilla/4.0 (MobilePhone PM-8200/US/1.0)
NetFront/3.1 MMP/2.0"

Then I get this in error_log:

[client] PHP Fatal error:  Class theme_program_listing: 
Cannot inherit from undefined class theme in
/var/www/html/mythweb/themes/wml/program_listing.php on line 11

It would appear that my phone IS being detected correctly but I don't
know what that error means.  Either way, I get nothing but a blank
screen on my phone or other emulators.

Thanks for any tips,

On Mon, 28 Feb 2005 09:13:43 -0800, Chris Petersen
<lists at forevermore.net> wrote:
> > I want to have Mythweb working so that it lets you access it from a PC
> > using the default theme, but also from a phone by using a more compact
> > theme such as wap. I would have thought that would be possible by
> > entering different URLs but the way I understand it at the moment you
> > can either have it running with the Default theme or the Wap theme,
> > but not both.
> WML (for phones) should be auto-detected based on the phone's useragent
> string.  The WAP theme is currently outdated, and most phones use WML,
> anyway.
> If your phone's useragent isn't detected, send it to me and I'll add it
> to the list.
> -Chris
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list