[mythtv-users] Big headaches trying to get LIRC working

Jason Donahue mythtv at timekiller.org
Sun Feb 27 22:22:00 UTC 2005

I actually did re-read the lirc section of the howto. I applied the
patch, and removed the first line of lirc.rules. I think it may be an
issue with my modprobe.conf.

I kind of guessed at the appropriate line:

alias char-major-61 lirc_mceusb

With this line I just noticed that even if the receiver is not plugged
in, the lirc_mceusb and lirc_dev modules get loaded on reboot. If I
manually unload them, and plug in the receiver they don't get loaded. So
it seems there is something wrong.

I've also tried:

alias lirc0 lirc_mceusb

Anyone know what the modprobe.conf line should be?

On Sun, 2005-02-27 at 11:04 -0800, Jarod Wilson wrote:
> On Sunday 27 February 2005 10:57, Jason Donahue wrote:
> > I have several Myth Boxes, and have done a bunch of installs, mainly
> > based around Jarod's HOWTO.
> >
> > Currently I am trying to get a USB XP MCE receiver working on a front-
> > end only box.
> >
> > I have everything installed, and the proper module loads when I plug in
> > the receiver.
> >
> > The main problem is that /dev/lirc0 is not getting created, so nothing
> > works.
> >
> > What do I need to do to get /dev/lirc0 created ? I even tried creating
> > it with mknod, but when I manually create it, things like irw and
> > irrecord seg fault.
> >
> > Any help is appreciated...
> Re-read the lirc parts in my latest doc rev. There's a patch for rc.sysinit 
> and a udev rules file needed to get everything to auto-load properly at 
> startup.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list