[mythtv-users] Upgrade failure / problem 0.17

Ken Bass kbass at kenbass.com
Sun Feb 27 18:40:58 UTC 2005

Hi all, I've upgraded last night to 0.17 but all is not well.

I went from 0.15 to 0.17

When I ran the backend it said it updated the schema fine.
When I ran the frontend it had the following problem:

2005-02-26 23:34:11.984 Upgrading to schema version 1051
2005-02-26 23:34:12.040 DB Error (Performing database upgrade):
Query was: ALTER TABLE recorded ADD COLUMN lastmodified TIMESTAMP NOT NULL;
Error was: Driver error was [2/-1]:
QMYSQL3: Unable to execute query
Database error was:
Duplicate column name 'lastmodified'

new version: 1051
2005-02-26 23:34:12.040 Couldn't upgrade database to new schema, exiting.

Following some archive advice for two other schema issues I did
a ALTER TABLE recorder DROP COLUMN lastmodified;

Then I reran the frontend which appeared to work. However, all me 
recorded programs are missing. First, I assume they are now suppose to 
be present in the 'Media Libary' area? (things have changed from 0.15 - 
the familiar watch recording is gone). Second, the Media Library is 
empty. All recordings are still in /mnt/store however.

Two additional programs recorded this morning but even those new ones 
are not there. Am I looking in the wrong place? It Media Library for a 
plug-in? I made pressed 'm' at this spot and selected 'All Recordings' - 
but nothing.

The wife is on the her way home, please help! ;)

More information about the mythtv-users mailing list