[mythtv-users] ivtv errors after dist-upgrade

Scott Alfter mythtv at salfter.dyndns.org
Thu Dec 22 00:04:24 EST 2005

sdk wrote:
> There were a decent amount of new packages, so I decided to update
> with apt-get update and then apt-get dist-upgrade on FC3.
> capture card: PVR-350
> Kernel(which was upgraded during the install): 2.6.12-1.1381_FC3

Since you upgraded the kernel, you might have some duplicate modules filed
under both /lib/modules/2.6.12.blahblah (from the kernel) and in a non-kernel
location under /lib/modules (from ivtv).  Locate the modules that were
installed with ivtv and search the kernel modules for the same names.  Some
likely culprits are tuner.ko, tveeprom.ko, and tda9887.ko; you may have some
others as well.

Once you've found the extras, remove them from the kernel directory, unload all
of the modules and modprobe ivtv.  All should be well, as the ivtv versions of
all of these modules should now be in use.

(Shameless plug for Gentoo: When you install ivtv, the ebuild checks for
duplicate modules provided by the kernel and advises you to move/delete them.)

 / v \ Scott Alfter
(IIGS( http://alfter.us/            Top-posting!
 \_^_/ rm -rf /bin/laden            >What's the most annoying thing on Usenet?

More information about the mythtv-users mailing list